summaryrefslogtreecommitdiff
path: root/dev-util/source-highlight
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-util/source-highlight
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-util/source-highlight')
-rw-r--r--dev-util/source-highlight/Manifest4
-rw-r--r--dev-util/source-highlight/files/source-highlight-3.1.9-test-clang-p1.patch30
-rw-r--r--dev-util/source-highlight/files/source-highlight-3.1.9-test-clang-p2.patch39
-rw-r--r--dev-util/source-highlight/source-highlight-3.1.9.ebuild5
4 files changed, 77 insertions, 1 deletions
diff --git a/dev-util/source-highlight/Manifest b/dev-util/source-highlight/Manifest
index 9fec10d7dedf..d50152921654 100644
--- a/dev-util/source-highlight/Manifest
+++ b/dev-util/source-highlight/Manifest
@@ -1,3 +1,5 @@
+AUX source-highlight-3.1.9-test-clang-p1.patch 998 BLAKE2B 7867aff751170990c48343977f6d92380c1f84ad8f18d9def453b39c6e6a8b97f23727f6cb1419f0b9d82f0fc368517d19f321f23752410ba84fb1cf6335d5dd SHA512 b64f44a9f5c1fff05aaa1a6f025d61cc095e9f22944a1983aca457085f348535ad27a7b7f79ec6358f64fc72fa0869ee3c22659f44f1a0d105ef23d68f466c32
+AUX source-highlight-3.1.9-test-clang-p2.patch 1413 BLAKE2B f66b090bb5004cf4ee344868479b1a1999339d71799e6e6150104f99c0a8ea5ffebe836b8d185ecb52416aaed6da80e24c5870910274ce381cfab6ab3276035c SHA512 a6573d376753dda6e8f64dd9b81c4e8f209ea5cb3dee1dc9a495db6b671d88840baa2fd9c128085cb62d9acbc41e1f88d3a9e6a319b76199755b43008d7ab0de
DIST source-highlight-3.1.9.tar.gz 1717234 BLAKE2B 6eb40b2274df0772c4a241504e5db5dfdaac600549e0b11aba726f7b4d5ab600c3849a8815bc782ad1bb1f99b69766527645dd202731bde4b2466c663842c47c SHA512 d8e154e9a5d62c77807e4e5d36c0faed5ce2964291be5f8b83e2968a6de52229503689a4ca2109a717ae2632a14b63ec937ca0430c91684c72063f6bc0294195
-EBUILD source-highlight-3.1.9.ebuild 1398 BLAKE2B 829ccc78484078881ecdb1d2f321d625996cc88a97b8f5cb4e96587a15db0b58893a0c16d4de26ac4e404b378e1468ea4ff345d582b871a674ee1cc4b2b7776b SHA512 8a2263143b563610076489b199795aa4b0de29ebe3caf1724bf37adac3e0d3ac15330d4f915ccbe7dab5786d172d2188407eedfbee4fb73f035eb6e1da0dbbac
+EBUILD source-highlight-3.1.9.ebuild 1505 BLAKE2B a630a478ced8369ceb95e8b9cf8bd934444da64cc128079d6385c92fc329911e313deebf5d50bad1d5c4faacabef9a8501ec6859cff8e745e6b0f827a0f4853f SHA512 d59500bb398d6a2e89382c22514dd364af3f26bb698acd5392e14ecd966edbfb3bb2558295beaace6f1e7b279318194ac36c2a6fbf11bdbc5a4be5c34bbcb4db
MISC metadata.xml 267 BLAKE2B 5267526ad53ec7bedfe46f8cba86c810629394fa4f3c59e1b69619b0a11a9edbb746ae6abf818182da7ade72c862360f43a19209007a23da9701df26b96f77dd SHA512 715bb37d958c1e508b2ef00711ab3a4abee982efe90867fd2bcf91fa91305d5a413a4f3d13d01ea6e27eb15f5f9dcb58fa13ecfed7025cae43745792ac1a105d
diff --git a/dev-util/source-highlight/files/source-highlight-3.1.9-test-clang-p1.patch b/dev-util/source-highlight/files/source-highlight-3.1.9-test-clang-p1.patch
new file mode 100644
index 000000000000..6b0bad369b86
--- /dev/null
+++ b/dev-util/source-highlight/files/source-highlight-3.1.9-test-clang-p1.patch
@@ -0,0 +1,30 @@
+From b3481e66f2014dece48d8dfe8affa416d8d4e104 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Thu, 27 Aug 2020 07:51:14 +0100
+Subject: [PATCH 1/2] lib/tests/stdboosterror.h: use unambiguous form of
+ variable declaration
+
+Original expression has an ambiguity and should not compile:
+https://gcc.gnu.org/PR86564
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ lib/tests/stdboosterror.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/tests/stdboosterror.h b/lib/tests/stdboosterror.h
+index 568545b..d59bfa6 100644
+--- a/lib/tests/stdboosterror.h
++++ b/lib/tests/stdboosterror.h
+@@ -4,7 +4,7 @@
+ #include <boost/regex/pattern_except.hpp>
+
+ static boost::regex_error
+- std_boost_exception(boost::regex_error(boost::regex_constants::error_bad_pattern));
++ std_boost_exception = boost::regex_error(boost::regex_constants::error_bad_pattern);
+
+ /**
+ * returns the string representing a standard exception (which
+--
+2.28.0
+
diff --git a/dev-util/source-highlight/files/source-highlight-3.1.9-test-clang-p2.patch b/dev-util/source-highlight/files/source-highlight-3.1.9-test-clang-p2.patch
new file mode 100644
index 000000000000..4c34f9dcca51
--- /dev/null
+++ b/dev-util/source-highlight/files/source-highlight-3.1.9-test-clang-p2.patch
@@ -0,0 +1,39 @@
+From 4d53621557de31479dad3cb44b7fccba8277b76d Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Thu, 27 Aug 2020 07:52:25 +0100
+Subject: [PATCH 2/2] lib/tests/test_wordtokenizer_main.cpp: insert overload to
+ std namespace
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ lib/tests/test_wordtokenizer_main.cpp | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/lib/tests/test_wordtokenizer_main.cpp b/lib/tests/test_wordtokenizer_main.cpp
+index 40e23b1..02e8fd8 100644
+--- a/lib/tests/test_wordtokenizer_main.cpp
++++ b/lib/tests/test_wordtokenizer_main.cpp
+@@ -11,9 +11,9 @@
+ using namespace std;
+ using namespace srchilite;
+
+-static ostream &operator <<(ostream &os, const WordTokenizer::WordTokenizerResults::value_type &);
+-
+-ostream &operator <<(ostream &os, const WordTokenizer::WordTokenizerResults::value_type &token) {
++/* Argument-dependent lookup looks only at std:: namespace (ostream and value_type expansion) */
++namespace std {
++static ostream &operator <<(ostream &os, const WordTokenizer::WordTokenizerResults::value_type &token) {
+ if (token.first.size()) {
+ os << "space: \"" << token.first << "\"" << endl;
+ } else {
+@@ -22,6 +22,7 @@ ostream &operator <<(ostream &os, const WordTokenizer::WordTokenizerResults::val
+
+ return os;
+ }
++}
+
+ int main() {
+ WordTokenizer::WordTokenizerResults tokens;
+--
+2.28.0
+
diff --git a/dev-util/source-highlight/source-highlight-3.1.9.ebuild b/dev-util/source-highlight/source-highlight-3.1.9.ebuild
index cbf7b16e377f..3568b4c32e0d 100644
--- a/dev-util/source-highlight/source-highlight-3.1.9.ebuild
+++ b/dev-util/source-highlight/source-highlight-3.1.9.ebuild
@@ -18,6 +18,11 @@ RDEPEND=">=dev-libs/boost-1.62.0:=[threads]
DEPEND="${RDEPEND}"
BDEPEND=""
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.9-test-clang-p1.patch
+ "${FILESDIR}"/${PN}-3.1.9-test-clang-p2.patch
+)
+
src_configure() {
# required as rev-dep of dev-libs/boost-1.62.0
# https://wiki.gentoo.org/wiki/Project:C%2B%2B/Maintaining_ABI