summaryrefslogtreecommitdiff
path: root/dev-util/skipfish/skipfish-2.10_beta.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/skipfish/skipfish-2.10_beta.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/skipfish/skipfish-2.10_beta.ebuild')
-rw-r--r--dev-util/skipfish/skipfish-2.10_beta.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/skipfish/skipfish-2.10_beta.ebuild b/dev-util/skipfish/skipfish-2.10_beta.ebuild
new file mode 100644
index 000000000000..81bb804912a3
--- /dev/null
+++ b/dev-util/skipfish/skipfish-2.10_beta.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs vcs-snapshot versionator
+
+MY_COMMIT_HASH="093800c9de4116706258982376abce01928a3f7b"
+
+DESCRIPTION="A fully automated, active web application security reconnaissance tool"
+HOMEPAGE="https://github.com/spinkham/skipfish"
+SRC_URI="https://github.com/spinkham/${PN}/archive/${MY_COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/openssl:0
+ dev-libs/libpcre
+ net-dns/libidn
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS_GEN/s:-g -ggdb::' \
+ -e '/CFLAGS_OPT/s:-O3::' \
+ Makefile || die
+
+ sed -i \
+ -e "/ASSETS_DIR/s:assets:/usr/share/doc/${PF}/html:" \
+ -e "/SIG_FILE/s:signatures/:/etc/skipfish/signatures/:" \
+ src/config.h || die
+
+ sed -i \
+ -e "s:signatures/:/etc/skipfish/signatures/:g" \
+ signatures/signatures.conf || die
+}
+
+src_compile() {
+ tc-export CC
+
+ local _debug
+ use debug && _debug=debug
+
+ emake ${_debug}
+}
+
+src_install() {
+ dobin ${PN}
+ doman doc/${PN}.1
+
+ insinto /etc/skipfish
+ doins -r signatures
+
+ insinto /usr/share/${PN}/dictionaries
+ doins dictionaries/*.wl
+
+ dohtml assets/*
+
+ dodoc ChangeLog README doc/*.txt
+}