summaryrefslogtreecommitdiff
path: root/dev-util/shtool/shtool-2.0.8-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
commitc9e9e39938097bf29063c271195ad0d7d7bd02a9 (patch)
treef2f4ab36d22272fec3a1d1313d8f700b1f0f6744 /dev-util/shtool/shtool-2.0.8-r2.ebuild
parent0968caae52d6eae7513e2ce4e0900a2e009780ee (diff)
gentoo auto-resync : 17:09:2023 - 17:03:44
Diffstat (limited to 'dev-util/shtool/shtool-2.0.8-r2.ebuild')
-rw-r--r--dev-util/shtool/shtool-2.0.8-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/shtool/shtool-2.0.8-r2.ebuild b/dev-util/shtool/shtool-2.0.8-r2.ebuild
new file mode 100644
index 000000000000..d80eeac9c3a9
--- /dev/null
+++ b/dev-util/shtool/shtool-2.0.8-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Set of stable and portable shell scripts"
+HOMEPAGE="https://www.gnu.org/software/shtool/shtool.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sparc ~x86"
+
+DEPEND="dev-lang/perl"
+DOCS=( AUTHORS ChangeLog README THANKS VERSION NEWS RATIONAL )
+
+src_prepare() {
+ default
+ sed -i "s|opt_C=\"ar\"|opt_C=\"$(tc-getAR)\"|g" sh.arx || die
+}