summaryrefslogtreecommitdiff
path: root/dev-util/shflags/shflags-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/shflags/shflags-1.0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/shflags/shflags-1.0.3.ebuild')
-rw-r--r--dev-util/shflags/shflags-1.0.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/shflags/shflags-1.0.3.ebuild b/dev-util/shflags/shflags-1.0.3.ebuild
new file mode 100644
index 000000000000..a1bba5a8346f
--- /dev/null
+++ b/dev-util/shflags/shflags-1.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Command-line flags module for Unix shell scripts"
+HOMEPAGE="https://github.com/kward/shflags"
+SRC_URI="https://github.com/kward/shflags/archive/${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="examples"
+
+src_test() {
+ cd src || die
+ ./shflags_test.sh || die
+}
+
+src_install() {
+ dohtml README.html
+ dodoc README.txt doc/*.txt
+ insinto /usr/share/misc
+ doins src/shflags
+ use examples && dodoc examples/*.sh
+}