summaryrefslogtreecommitdiff
path: root/dev-util/shellcheck-bin/shellcheck-bin-0.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-util/shellcheck-bin/shellcheck-bin-0.7.0.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-util/shellcheck-bin/shellcheck-bin-0.7.0.ebuild')
-rw-r--r--dev-util/shellcheck-bin/shellcheck-bin-0.7.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/shellcheck-bin/shellcheck-bin-0.7.0.ebuild b/dev-util/shellcheck-bin/shellcheck-bin-0.7.0.ebuild
new file mode 100644
index 000000000000..8b6f2c39aa76
--- /dev/null
+++ b/dev-util/shellcheck-bin/shellcheck-bin-0.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${PN/-bin/}
+
+DESCRIPTION="Shell script analysis tool (binary package)"
+HOMEPAGE="https://www.shellcheck.net/"
+SRC_URI="
+ amd64? ( https://storage.googleapis.com/${MY_PN}/${MY_PN}-v${PV}.linux.x86_64.tar.xz )
+ arm? ( https://storage.googleapis.com/${MY_PN}/${MY_PN}-v${PV}.linux.armv6hf.tar.xz )
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+DEPEND="!dev-util/shellcheck"
+RDEPEND="${DEPEND}"
+
+QA_PREBUILT="/usr/bin/shellcheck"
+S="${WORKDIR}/${MY_PN}-v${PV}"
+
+src_install() {
+ dobin shellcheck
+ einstalldocs
+}