summaryrefslogtreecommitdiff
path: root/dev-util/shards/shards-0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/shards/shards-0.7.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/shards/shards-0.7.1.ebuild')
-rw-r--r--dev-util/shards/shards-0.7.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/shards/shards-0.7.1.ebuild b/dev-util/shards/shards-0.7.1.ebuild
new file mode 100644
index 000000000000..38b42f417a5c
--- /dev/null
+++ b/dev-util/shards/shards-0.7.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Dependency manager for the Crystal language"
+HOMEPAGE="https://github.com/crystal-lang/shards"
+SRC_URI="https://github.com/crystal-lang/shards/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >dev-lang/crystal-0.11.1[yaml]
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT=test # missing files in tarball
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+}