summaryrefslogtreecommitdiff
path: root/dev-util/shards/shards-0.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-util/shards/shards-0.15.0.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-util/shards/shards-0.15.0.ebuild')
-rw-r--r--dev-util/shards/shards-0.15.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/shards/shards-0.15.0.ebuild b/dev-util/shards/shards-0.15.0.ebuild
new file mode 100644
index 000000000000..52270b880ee8
--- /dev/null
+++ b/dev-util/shards/shards-0.15.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing toolchain-funcs
+
+CRYSTAL_MOLINILLO_PV=0.2.0
+CRYSTAL_MOLINILLO_P=crystal-molinillo-${CRYSTAL_MOLINILLO_PV}
+
+DESCRIPTION="Dependency manager for the Crystal language"
+HOMEPAGE="https://github.com/crystal-lang/shards"
+SRC_URI="
+ https://github.com/crystal-lang/shards/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/crystal-lang/crystal-molinillo/archive/v${CRYSTAL_MOLINILLO_PV}.tar.gz -> ${CRYSTAL_MOLINILLO_P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >dev-lang/crystal-0.11.1[yaml]
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT=test # missing files in tarball
+
+src_prepare() {
+ default
+
+ # bundle crystal-molinillo to bootstrap 'shards'
+ mkdir -p lib || die
+ ln -s ../../${CRYSTAL_MOLINILLO_P} lib/molinillo || die
+
+ tc-export CC
+}
+
+src_compile() {
+ emake release=1 FLAGS="--link-flags=\"${LDFLAGS}\" --verbose --threads $(makeopts_jobs)"
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+}