summaryrefslogtreecommitdiff
path: root/dev-util/sh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-27 23:40:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-27 23:40:34 +0000
commitfdd31f37b982d2c1b6d73b85f99718b13031be36 (patch)
treeb53698971171aec857ab0822be99fc89cac616c6 /dev-util/sh
parent5cf235d5f7f308ba0183f7fa588514966b692114 (diff)
gentoo auto-resync : 27:02:2024 - 23:40:33
Diffstat (limited to 'dev-util/sh')
-rw-r--r--dev-util/sh/Manifest4
-rw-r--r--dev-util/sh/sh-3.8.0.ebuild34
-rw-r--r--dev-util/sh/sh-9999.ebuild54
3 files changed, 37 insertions, 55 deletions
diff --git a/dev-util/sh/Manifest b/dev-util/sh/Manifest
index 9dc9344c99c1..f7b5218fee26 100644
--- a/dev-util/sh/Manifest
+++ b/dev-util/sh/Manifest
@@ -1,5 +1,7 @@
DIST sh-3.7.0-deps.tar.xz 9776560 BLAKE2B 2376bba34d0b57897f748ce277b8c40da2ac98ad518e516868c442a521b24e4e19016b26dd0e889157781fa75cc7f945dea72a0451937a3bef24d65149d8de7b SHA512 3baf5276b1916e726a99b47dcf1319fb9a015e6096d8dbd430df478f9dbc1ecbcffcb82de72efbb455aa4a6dc17437e00287df27abd2e7e126253171d7024a9e
DIST sh-3.7.0.tar.gz 219380 BLAKE2B 5de1f5576f3e92f5cc892da730b62640b0922f879005e844b3e0b0d84a4e8f1a5f76e89c53152dd3de11c67da20411c5bddd44627ab31b66a72f950b1bf03393 SHA512 5869b68d4bb59907ff7543019e02e8e1efee5963475763b2b2daf0b1ef8621d919d54978a50e52d865b5b76b188c821fecb673e6a9ce42b30cd9907a020e6387
+DIST sh-3.8.0-deps.tar.xz 3129756 BLAKE2B e8a7a6f4a699b55d2b2533065ff0030777fddcb444606889cbf0b811715e89af8f97fb28d1ed71e8bb9ee07517cf71930c03151c2f102c316902e6b55141ee85 SHA512 1bb8776d308aea471051002ba2c426d6a59b354e3615561e33f42938c55472e402b037651db8307d593be0489df30a0d99be3a4e0d75972a85266facebdab32e
+DIST sh-3.8.0.tar.gz 221631 BLAKE2B b2235c88d2601c0c223b8bc55682ee7490da7bf97696fdf3fa32787e5ef123bf4072e281daf29851695b590fe93f7bf180b03558974ad726fab10f799881ec92 SHA512 fbeba1883f9458c480663c31d51beaffb780205f5251cae956f6582d494109e21e062e444f7436db220fb647e833ec48498fa1f75daa7fa7ec88ba1f564d4213
EBUILD sh-3.7.0.ebuild 1136 BLAKE2B ef6ba3861e8d11ae56f86813e34debfef3e1b41a01747008a3cf2fd9bf68dbf57fc88606a8be2df3b4ea95fdb3ef2dd83493c7892597125fa0d98e701f380dc5 SHA512 daf31cd0b5007e1be410c1839d9e96b8fd3b46515c7a009658834791974fda02bc1c694027b75a2accd227ff8846601f3ee8038547b79dde0db4f87d85eb2374
-EBUILD sh-9999.ebuild 1136 BLAKE2B ef6ba3861e8d11ae56f86813e34debfef3e1b41a01747008a3cf2fd9bf68dbf57fc88606a8be2df3b4ea95fdb3ef2dd83493c7892597125fa0d98e701f380dc5 SHA512 daf31cd0b5007e1be410c1839d9e96b8fd3b46515c7a009658834791974fda02bc1c694027b75a2accd227ff8846601f3ee8038547b79dde0db4f87d85eb2374
+EBUILD sh-3.8.0.ebuild 854 BLAKE2B 5d86ee4ae91a99632a0576c966efd0ffa65acf7851e4f31248d5275112a78ba42f11db1073f02f93f87d9c5b1ccdc98fc39cbe3241448ae95e8f8d866190d0e5 SHA512 51e1d900b3bc8785cf0afcb8e5258f242b13d8a277c72d2909bc9d6b8d14e10f7bee4161bf6e2fc928605582203e5cc6e957622ff6eb6adb27ed88331f99d636
MISC metadata.xml 717 BLAKE2B 0f9d6a11056a5a0ba6e297601a55b88ea86ee47d08dba0da2b4367c71f2a8e5876f0513f4fc31fd0b63905ad89a9da57b95a90ecb2efce8009ef1f23dc14a109 SHA512 b9ad5206fb1d1e3e22751c6619f998635d8f17d31b75b9cc4e99516eff8ce875b4dc8597c5c25b16cc684312b3e3b458a674f5be557f4c286cf3a374716c8863
diff --git a/dev-util/sh/sh-3.8.0.ebuild b/dev-util/sh/sh-3.8.0.ebuild
new file mode 100644
index 000000000000..6aa0a0969770
--- /dev/null
+++ b/dev-util/sh/sh-3.8.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A shell parser, formatter, and interpreter with bash support"
+HOMEPAGE="https://github.com/mvdan/sh"
+SRC_URI="https://github.com/mvdan/sh/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+S="${WORKDIR}/${PN//fmt/}-${PV}"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+BDEPEND="app-text/scdoc"
+
+src_compile() {
+ # Not bothering with gosh for now as it's very new
+ # https://github.com/mvdan/sh#gosh
+ ego build ./cmd/shfmt
+ scdoc <cmd/shfmt/shfmt.1.scd >shfmt.1 || die "conversation of man page failed"
+}
+
+src_test() {
+ cd syntax || die
+ ego test -run=-
+}
+
+src_install() {
+ dobin shfmt
+ doman shfmt.1
+}
diff --git a/dev-util/sh/sh-9999.ebuild b/dev-util/sh/sh-9999.ebuild
deleted file mode 100644
index c85de409caf7..000000000000
--- a/dev-util/sh/sh-9999.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module
-
-DESCRIPTION="A shell parser, formatter, and interpreter with bash support"
-HOMEPAGE="https://github.com/mvdan/sh"
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://github.com/mvdan/sh.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/mvdan/sh/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
- S="${WORKDIR}/${PN//fmt/}-${PV}"
-fi
-
-LICENSE="Apache-2.0 BSD"
-SLOT="0"
-IUSE="+man"
-
-BDEPEND="man? ( app-text/scdoc )"
-
-src_unpack() {
- default
- if [[ ${PV} == *9999 ]]; then
- git-r3_src_unpack
- go-module_live_vendor
- fi
-}
-
-src_compile() {
- # Not bothering with gosh for now as it's very new
- # https://github.com/mvdan/sh#gosh
- ego build ./cmd/shfmt
- if use man; then
- scdoc <cmd/shfmt/shfmt.1.scd >shfmt.1 || die "conversation of man page failed"
- fi
-}
-
-src_test() {
- cd syntax || die
- ego test -run=-
-}
-
-src_install() {
- dobin shfmt
- if use man; then
- doman shfmt.1
- fi
-}