summaryrefslogtreecommitdiff
path: root/dev-util/sh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-26 14:59:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-26 14:59:08 +0100
commit1503b28e7a30c164cab750c27268f704b8a5cec6 (patch)
treed06a47a18b0fb792e95f88ea6e18af234eb0b9d5 /dev-util/sh
parent34ce8f465101950c92cb66c657d3244b5a8397db (diff)
gentoo auto-resync : 26:07:2022 - 14:59:07
Diffstat (limited to 'dev-util/sh')
-rw-r--r--dev-util/sh/Manifest4
-rw-r--r--dev-util/sh/metadata.xml11
-rw-r--r--dev-util/sh/sh-3.5.1.ebuild30
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/sh/Manifest b/dev-util/sh/Manifest
new file mode 100644
index 000000000000..d9058b436fa3
--- /dev/null
+++ b/dev-util/sh/Manifest
@@ -0,0 +1,4 @@
+DIST sh-3.5.1-deps.tar.xz 3113476 BLAKE2B 0998ebeacdd7c882542eea25ad5ab3131211c686ac2ba8040b89897a60ab41ecea7fc0c45f6498eda56a4539550622e2693fed0a6a1ed5ca6af060c40a9aaf97 SHA512 b572f7334e04365d3d685ba8b87fff834fb9823e815152646659d66e92410cab03940b5a32f6eb0634c4a0cce34808d03849d8b97b17fdbec939b305b13878e9
+DIST sh-3.5.1.tar.gz 222608 BLAKE2B a81af092d0f8d0ee7c05240d816a99f044bce3e35d242a815a238a27893db5bfc320efc4a0237ca9ecfa0276e4687152c87f6e0170f5326e2d0a8604f94f6adb SHA512 fd1084921254b70376b3ac47b97e2108308252fa6bd23aff1e59aaefb45a7e01c1738a46ae6f4eb255ecade77fb9659fbc8184d2473e8e4f70e520757bad506d
+EBUILD sh-3.5.1.ebuild 667 BLAKE2B bff7677fb283dd6f6290f700194b363abeeae3d037853d1c36d98d98ffed8b1ceff21c08cc020d33dc8d0ef4e20a249b2979e0316a3fdcab95a555510c89bc01 SHA512 c77a8e89f402680445c1d3aabde7aee6cdd697eb536cc08bdc41d1710246b1193b742d2cd32b05dd0a7a3ea1cab6d54b31b1e426330b9de5a7f401d169064bce
+MISC metadata.xml 313 BLAKE2B 17509142cbc5019a0566e03d41377d64c539a4dfd1d0458c5ea97d9d5962dde815fe9101b4d8aa4e0943589222278a255febb283af62441137c5752111b7ef4f SHA512 1d7462856c874a7dec084a7bb3d0f58e5aec0fbee61fc0f6bead7c559aba7a88b867779018f78d7ce42a657b2fc5dd192e0985325cdf9312abce4913216c9397
diff --git a/dev-util/sh/metadata.xml b/dev-util/sh/metadata.xml
new file mode 100644
index 000000000000..1e811dcb7fc9
--- /dev/null
+++ b/dev-util/sh/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mvdan/sh</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/sh/sh-3.5.1.ebuild b/dev-util/sh/sh-3.5.1.ebuild
new file mode 100644
index 000000000000..f5098aea771b
--- /dev/null
+++ b/dev-util/sh/sh-3.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A shell parser, formatter, and interpreter with bash support"
+HOMEPAGE="https://github.com/mvdan/sh"
+SRC_URI="https://github.com/mvdan/sh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ # Not bothering with gosh for now as it's very new
+ # https://github.com/mvdan/sh#gosh
+ ego build ./cmd/shfmt
+}
+
+src_test() {
+ cd syntax || die
+ ego test -run=-
+}
+
+src_install() {
+ dobin shfmt
+}