summaryrefslogtreecommitdiff
path: root/dev-util/setconf/setconf-0.6.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/setconf/setconf-0.6.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/setconf/setconf-0.6.7.ebuild')
-rw-r--r--dev-util/setconf/setconf-0.6.7.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/setconf/setconf-0.6.7.ebuild b/dev-util/setconf/setconf-0.6.7.ebuild
new file mode 100644
index 000000000000..1f5e27b579f0
--- /dev/null
+++ b/dev-util/setconf/setconf-0.6.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit python-single-r1
+
+DESCRIPTION="A small python based utility used to change configuration files"
+HOMEPAGE="http://setconf.roboticoverlords.org/"
+SRC_URI="http://${PN}.roboticoverlords.org/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=${PYTHON_DEPS}
+
+# "REQUIRED_USE is needed to have a (un-)nice error when someone disabled all of python3" -mgorny
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ unpack "./${PN}.1.gz"
+}
+
+src_prepare() {
+ python_fix_shebang -f "${PN}.py"
+}
+
+src_install() {
+ python_doscript "${PN}.py"
+ dosym "${PN}.py" "/usr/bin/${PN}"
+ doman "${PN}.1"
+}