summaryrefslogtreecommitdiff
path: root/dev-util/sccache/sccache-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-27 13:35:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-27 13:35:02 +0100
commitef593d1ec529be89d755077eee3869006d8c18ae (patch)
treee17a9fcd71c371059f0168cbdfe109c563536c27 /dev-util/sccache/sccache-9999.ebuild
parent61faa1ea0e8302df305bc281038fc00dc7eb1dd4 (diff)
gentoo auto-resync : 27:06:2023 - 13:35:02
Diffstat (limited to 'dev-util/sccache/sccache-9999.ebuild')
-rw-r--r--dev-util/sccache/sccache-9999.ebuild57
1 files changed, 36 insertions, 21 deletions
diff --git a/dev-util/sccache/sccache-9999.ebuild b/dev-util/sccache/sccache-9999.ebuild
index fd4f2ead86ad..2a99e5798f56 100644
--- a/dev-util/sccache/sccache-9999.ebuild
+++ b/dev-util/sccache/sccache-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 2017-2022 Gentoo Authors
+# Copyright 2017-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Autogenerated by pycargoebuild 0.7
+
EAPI=8
-# don't forget to add itoa-0.3.4 for tests https://bugs.gentoo.org/803512
CRATES="
"
@@ -12,30 +13,40 @@ inherit cargo optfeature systemd
DESCRIPTION="ccache/distcc like tool with support for rust and cloud storage"
HOMEPAGE="https://github.com/mozilla/sccache/"
-if [ ${PV} == "9999" ] ; then
+if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/mozilla/sccache.git"
else
- SRC_URI="https://github.com/mozilla/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- $(cargo_crate_uris ${CRATES})"
+ SRC_URI="
+ https://github.com/mozilla/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${CARGO_CRATE_URIS}
+ "
KEYWORDS="~amd64 ~ppc64"
fi
-LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 ISC MIT Unlicense ZLIB"
+LICENSE="Apache-2.0"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 BSD-2 BSD CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 ZLIB
+"
SLOT="0"
IUSE="azure dist-client dist-server gcs memcached redis s3 simple-s3"
+# See https://github.com/mozilla/sccache/issues/1820, hopefully temporary.
+RESTRICT="test"
REQUIRED_USE="s3? ( simple-s3 )"
-BDEPEND="virtual/pkgconfig"
-
+BDEPEND="
+ virtual/pkgconfig
+ >=virtual/rust-1.65
+"
DEPEND="
- sys-libs/zlib:=
app-arch/zstd
- dist-server? ( dev-libs/openssl:0= )
- gcs? ( dev-libs/openssl:0= )
+ sys-libs/zlib:=
+ dist-server? ( dev-libs/openssl:= )
+ gcs? ( dev-libs/openssl:= )
"
-
-RDEPEND="${DEPEND}
+RDEPEND="
+ ${DEPEND}
dist-server? ( sys-apps/bubblewrap )
"
@@ -51,6 +62,9 @@ src_unpack() {
}
src_configure() {
+ # Should be able to drop this once we have a 'gentoo' profile
+ sed -i 's/strip = true/strip = false/' Cargo.toml || die
+
myfeatures=(
native-zlib
$(usev azure)
@@ -62,9 +76,18 @@ src_configure() {
$(usev s3)
$(usev simple-s3)
)
+
cargo_src_configure --no-default-features
}
+src_test() {
+ if [[ "${PV}" == *9999* ]]; then
+ ewarn "tests are always broken for ${PV} (require network), skipping"
+ else
+ cargo_src_test
+ fi
+}
+
src_install() {
cargo_src_install
@@ -86,14 +109,6 @@ src_install() {
fi
}
-src_test() {
- if [[ "${PV}" == *9999* ]]; then
- ewarn "tests are always broken for ${PV} (require network), skipping"
- else
- cargo_src_test
- fi
-}
-
pkg_postinst() {
ewarn "${PN} is experimental, please use with care"
use memcached && optfeature "memcached backend support" net-misc/memcached