summaryrefslogtreecommitdiff
path: root/dev-util/scanmem/scanmem-0.16.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/scanmem/scanmem-0.16.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/scanmem/scanmem-0.16.1.ebuild')
-rw-r--r--dev-util/scanmem/scanmem-0.16.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/scanmem/scanmem-0.16.1.ebuild b/dev-util/scanmem/scanmem-0.16.1.ebuild
new file mode 100644
index 000000000000..7c226726a1fc
--- /dev/null
+++ b/dev-util/scanmem/scanmem-0.16.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit autotools eutils python-single-r1
+
+DESCRIPTION="Locate and modify variables in executing processes"
+HOMEPAGE="https://github.com/scanmem/scanmem"
+SRC_URI="https://github.com/scanmem/scanmem/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+DEPEND="sys-libs/readline:="
+RDEPEND="${DEPEND}
+ gui? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3
+ sys-auth/polkit
+ )"
+
+REQUIRED_USE="gui? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use gui && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ sed -i "/CFLAGS/d" Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-readline
+ $(use_enable gui)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use gui ; then
+ docinto gui
+ dodoc gui/{README,TODO}
+ python_fix_shebang "${D}"
+ fi
+}