summaryrefslogtreecommitdiff
path: root/dev-util/rosinstall
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-util/rosinstall
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-util/rosinstall')
-rw-r--r--dev-util/rosinstall/Manifest4
-rw-r--r--dev-util/rosinstall/rosinstall-0.7.8.ebuild41
-rw-r--r--dev-util/rosinstall/rosinstall-9999.ebuild41
3 files changed, 40 insertions, 46 deletions
diff --git a/dev-util/rosinstall/Manifest b/dev-util/rosinstall/Manifest
index 71fb16ea5d2a..1a3b74cb280a 100644
--- a/dev-util/rosinstall/Manifest
+++ b/dev-util/rosinstall/Manifest
@@ -1,4 +1,4 @@
DIST rosinstall-0.7.8.tar.gz 26430 BLAKE2B fae82276f5376a94914272e60b2e3b0f81cb37bd7b41e0a4df73c8b58d19a73505a0c5e193495fd59c931c04265cbb372abfad19fd4043fc77e5224127bd97f5 SHA512 a53ae8fb96f9dda4671b22dfd9dbadc18d1e4adbf34a50b6706baf971c1c7ee418e14641d334346b02638f06c10d1bc984b4759c92a39510dd0044fbc346be67
-EBUILD rosinstall-0.7.8.ebuild 1545 BLAKE2B a3c73b17a9516ef032ebe314c957f47741bfde4628c708d25571ee20e5ca5514ea46f02f2f27dbf3daa889f640dc66f73e8dc4e2c70fdac8ad1316b12f76ce84 SHA512 371e493fc470411d558260373cb8a19c85d7065d4f5ae7d511179b58d9abe0821ad9ae407896811e11aef1f40270325ee67ad91aae9b66cf6a38e54b01f8a6c8
-EBUILD rosinstall-9999.ebuild 1545 BLAKE2B a3c73b17a9516ef032ebe314c957f47741bfde4628c708d25571ee20e5ca5514ea46f02f2f27dbf3daa889f640dc66f73e8dc4e2c70fdac8ad1316b12f76ce84 SHA512 371e493fc470411d558260373cb8a19c85d7065d4f5ae7d511179b58d9abe0821ad9ae407896811e11aef1f40270325ee67ad91aae9b66cf6a38e54b01f8a6c8
+EBUILD rosinstall-0.7.8.ebuild 1490 BLAKE2B add7a7f86eeb05a45e14613d5e895de63449104390721f52bf4d67bb4d3f594fe0dac735d5ec59409b8dbcbf8f13962d31578a6a0affd8e88991fc8df7c03ef2 SHA512 6b4195663f55d7daa95e17ca833abc0a2f9d4037e782aeceb0b0492f1ef0f52d1abbd81c37275c932c97124d3715989f2256351ee71c10e34ac24fb2e01f2af5
+EBUILD rosinstall-9999.ebuild 1490 BLAKE2B add7a7f86eeb05a45e14613d5e895de63449104390721f52bf4d67bb4d3f594fe0dac735d5ec59409b8dbcbf8f13962d31578a6a0affd8e88991fc8df7c03ef2 SHA512 6b4195663f55d7daa95e17ca833abc0a2f9d4037e782aeceb0b0492f1ef0f52d1abbd81c37275c932c97124d3715989f2256351ee71c10e34ac24fb2e01f2af5
MISC metadata.xml 334 BLAKE2B 122018b9b2cb34c070abad5e4f6ba6400f240279013fd76f711d5aad1a7cc29e7d811ddf667046ebf46d997d2786deb2fead1f5249a81ea14191e26a9e420a54 SHA512 3bdac7021be057bbf3491275f84095cc315353ca802befc35440971834346d7f3f7957ba143493b04ca5571e7bb6fe65c79644bb0ace6937cc40fa6f00a6ae26
diff --git a/dev-util/rosinstall/rosinstall-0.7.8.ebuild b/dev-util/rosinstall/rosinstall-0.7.8.ebuild
index e77de122d88a..9ad54ef86e60 100644
--- a/dev-util/rosinstall/rosinstall-0.7.8.ebuild
+++ b/dev-util/rosinstall/rosinstall-0.7.8.ebuild
@@ -1,21 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/vcstools/rosinstall"
-fi
-
-inherit ${SCM} distutils-r1
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+inherit distutils-r1
DESCRIPTION="Command-line tools for maintaining a workspace of projects for ROS"
HOMEPAGE="https://wiki.ros.org/rosinstall https://wiki.ros.org/roslocate"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vcstools/rosinstall"
else
SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
https://github.com/vcstools/rosinstall/archive/${PV}.tar.gz -> ${P}.tar.gz
@@ -25,8 +22,6 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/catkin_pkg[${PYTHON_USEDEP}]
@@ -34,9 +29,8 @@ RDEPEND="
dev-python/rosdistro[${PYTHON_USEDEP}]
>=dev-util/wstool-0.1.12[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
+BDEPEND="${RDEPEND}
test? (
- dev-python/nose[${PYTHON_USEDEP}]
dev-vcs/git
dev-vcs/bzr
dev-vcs/mercurial
@@ -44,17 +38,20 @@ DEPEND="${RDEPEND}
)
"
-python_test() {
+distutils_enable_tests nose
+
+src_test() {
# From travis.yml
# Set git config to silence some stuff in the tests
- git config --global user.email "foo@example.com"
- git config --global user.name "Foo Bar"
+ git config --global user.email "foo@example.com" || die
+ git config --global user.name "Foo Bar" || die
# Set the hg user
- echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc || die
# Set the bzr user
- bzr whoami "Your Name <name@example.com>"
+ bzr whoami "Your Name <name@example.com>" || die
# command to run tests
# Local tests work even if ros.org is down
- export ROSINSTALL_SKIP_PYTHON3=1
- nosetests test || die
+ local -x ROSINSTALL_SKIP_PYTHON3=1
+
+ distutils-r1_src_test
}
diff --git a/dev-util/rosinstall/rosinstall-9999.ebuild b/dev-util/rosinstall/rosinstall-9999.ebuild
index e77de122d88a..9ad54ef86e60 100644
--- a/dev-util/rosinstall/rosinstall-9999.ebuild
+++ b/dev-util/rosinstall/rosinstall-9999.ebuild
@@ -1,21 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/vcstools/rosinstall"
-fi
-
-inherit ${SCM} distutils-r1
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+inherit distutils-r1
DESCRIPTION="Command-line tools for maintaining a workspace of projects for ROS"
HOMEPAGE="https://wiki.ros.org/rosinstall https://wiki.ros.org/roslocate"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vcstools/rosinstall"
else
SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
https://github.com/vcstools/rosinstall/archive/${PV}.tar.gz -> ${P}.tar.gz
@@ -25,8 +22,6 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/catkin_pkg[${PYTHON_USEDEP}]
@@ -34,9 +29,8 @@ RDEPEND="
dev-python/rosdistro[${PYTHON_USEDEP}]
>=dev-util/wstool-0.1.12[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
+BDEPEND="${RDEPEND}
test? (
- dev-python/nose[${PYTHON_USEDEP}]
dev-vcs/git
dev-vcs/bzr
dev-vcs/mercurial
@@ -44,17 +38,20 @@ DEPEND="${RDEPEND}
)
"
-python_test() {
+distutils_enable_tests nose
+
+src_test() {
# From travis.yml
# Set git config to silence some stuff in the tests
- git config --global user.email "foo@example.com"
- git config --global user.name "Foo Bar"
+ git config --global user.email "foo@example.com" || die
+ git config --global user.name "Foo Bar" || die
# Set the hg user
- echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc || die
# Set the bzr user
- bzr whoami "Your Name <name@example.com>"
+ bzr whoami "Your Name <name@example.com>" || die
# command to run tests
# Local tests work even if ros.org is down
- export ROSINSTALL_SKIP_PYTHON3=1
- nosetests test || die
+ local -x ROSINSTALL_SKIP_PYTHON3=1
+
+ distutils-r1_src_test
}