summaryrefslogtreecommitdiff
path: root/dev-util/rosinstall
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/rosinstall
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/rosinstall')
-rw-r--r--dev-util/rosinstall/Manifest5
-rw-r--r--dev-util/rosinstall/metadata.xml11
-rw-r--r--dev-util/rosinstall/rosinstall-0.7.8.ebuild60
-rw-r--r--dev-util/rosinstall/rosinstall-9999.ebuild60
4 files changed, 136 insertions, 0 deletions
diff --git a/dev-util/rosinstall/Manifest b/dev-util/rosinstall/Manifest
new file mode 100644
index 000000000000..27442e0d25df
--- /dev/null
+++ b/dev-util/rosinstall/Manifest
@@ -0,0 +1,5 @@
+DIST rosinstall-0.7.8.tar.gz 26430 SHA256 2ba808bf8bac2cc3f13af9745184b9714c1426e11d09eb96468611b2ad47ed40 SHA512 a53ae8fb96f9dda4671b22dfd9dbadc18d1e4adbf34a50b6706baf971c1c7ee418e14641d334346b02638f06c10d1bc984b4759c92a39510dd0044fbc346be67 WHIRLPOOL ef84d3cc5c37792a6b1b7c85b8ae2caa9cf8ed36a3150c3270a9230a1cec32597041db7d73a03ed57cb2686d0791fb5c36764ea79518c6da6a9bca4e358e83a7
+EBUILD rosinstall-0.7.8.ebuild 1538 SHA256 e301f061737a15d4067e9541e2574cfcb8d163d241823213c476eacd5a7b70ef SHA512 7b80df325b9886f529c41fd03f0ee470c10d0559c9ae922c1a326b2e4683b62610a849b755d2d5b1c3ed6871d64851998837538b39fb79b00030ae10db311721 WHIRLPOOL 30fe9ba44c8890c8d9a87a85d5c7ebf449b21b870d99a2f0771b369a2af456e5834044d751f6336cd4039277b529c11b7a9dfa5f331029af3f344fcf705f406f
+EBUILD rosinstall-9999.ebuild 1538 SHA256 e301f061737a15d4067e9541e2574cfcb8d163d241823213c476eacd5a7b70ef SHA512 7b80df325b9886f529c41fd03f0ee470c10d0559c9ae922c1a326b2e4683b62610a849b755d2d5b1c3ed6871d64851998837538b39fb79b00030ae10db311721 WHIRLPOOL 30fe9ba44c8890c8d9a87a85d5c7ebf449b21b870d99a2f0771b369a2af456e5834044d751f6336cd4039277b529c11b7a9dfa5f331029af3f344fcf705f406f
+MISC ChangeLog 1469 SHA256 294012fe317fcc448268f7b34c013015a68be1e525d86cf18e61863e9268234d SHA512 25065f27bad42617be7a0e96f39e87bdcdcb72b7389d44d21971588fd0a3a4e536fbd39eb6f623e7c28d1592028f4e000e421097d6f620f0ce208de1b7eac0de WHIRLPOOL 8cf31aecbfbb120c26401afb4abe50a2a13f1db69d20e9d8533e8c20f42a028654bb2efb52f219583fd7c0e692435efd21a89ae72c79d0a907bbb554a8b0e230
+MISC metadata.xml 333 SHA256 df3d2d537603577520d2c9bb5e4212b7dad37be54b4b1e9089d4edf0da4ea095 SHA512 5c6ef4930985cd5c2ea51b18a25d7cc2a5e387bdbd26e42f8710d6ce903cf13fe85ee1f1d13a0ffe82c8056dd295a3e25268ec58353508f30bf10404ae4ffb8a WHIRLPOOL 19d6efcb5258e8fefa3de1312350939c50faad71a23e5fae2b4bccd63c44a9641c9fe7cff1232daef2dd790eff8b62ad856624090e8566883d65eff8acb6ca9a
diff --git a/dev-util/rosinstall/metadata.xml b/dev-util/rosinstall/metadata.xml
new file mode 100644
index 000000000000..22544f9d5e39
--- /dev/null
+++ b/dev-util/rosinstall/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vcstools/rosinstall</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/rosinstall/rosinstall-0.7.8.ebuild b/dev-util/rosinstall/rosinstall-0.7.8.ebuild
new file mode 100644
index 000000000000..421784382161
--- /dev/null
+++ b/dev-util/rosinstall/rosinstall-0.7.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/rosinstall"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Command-line tools for maintaining a workspace of projects for ROS"
+HOMEPAGE="http://wiki.ros.org/rosinstall http://wiki.ros.org/roslocate"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/rosinstall/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ >=dev-util/wstool-0.1.12[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ app-shells/zsh
+ )
+"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ # Local tests work even if ros.org is down
+ export ROSINSTALL_SKIP_PYTHON3=1
+ nosetests test || die
+}
diff --git a/dev-util/rosinstall/rosinstall-9999.ebuild b/dev-util/rosinstall/rosinstall-9999.ebuild
new file mode 100644
index 000000000000..421784382161
--- /dev/null
+++ b/dev-util/rosinstall/rosinstall-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/rosinstall"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Command-line tools for maintaining a workspace of projects for ROS"
+HOMEPAGE="http://wiki.ros.org/rosinstall http://wiki.ros.org/roslocate"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/rosinstall/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ >=dev-util/wstool-0.1.12[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ app-shells/zsh
+ )
+"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ # Local tests work even if ros.org is down
+ export ROSINSTALL_SKIP_PYTHON3=1
+ nosetests test || die
+}