summaryrefslogtreecommitdiff
path: root/dev-util/rosdep
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-util/rosdep
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-util/rosdep')
-rw-r--r--dev-util/rosdep/Manifest5
-rw-r--r--dev-util/rosdep/files/tests.patch33
-rw-r--r--dev-util/rosdep/rosdep-0.19.0-r1.ebuild (renamed from dev-util/rosdep/rosdep-0.19.0.ebuild)11
-rw-r--r--dev-util/rosdep/rosdep-9999.ebuild11
4 files changed, 52 insertions, 8 deletions
diff --git a/dev-util/rosdep/Manifest b/dev-util/rosdep/Manifest
index aa768acc086e..0c1d72ad3571 100644
--- a/dev-util/rosdep/Manifest
+++ b/dev-util/rosdep/Manifest
@@ -1,4 +1,5 @@
+AUX tests.patch 1578 BLAKE2B c83b381010e29052a51f9dfb9a9ac24e9076caa23194deb1c7062b56f83bd03dce6281038541cca6c9353c2eaf90b5bbd6eaa9447ae5868b3e56e4f870be3908 SHA512 da349f614bd497dbe1437eb841657183c1b623fb3d4a933c9fe0202dd1dab741cb962370efb56cb8f11f51b70da106033fa9aafbc9d8f36e3ec1729fe6b5ec74
DIST rosdep-0.19.0.tar.gz 309029 BLAKE2B d4d9f607757c418f848a89987db6ff17a98719d0cacab49250abf45145a9f5b538d9442622ec3a8c3536061e82e624f25c9a7b777662b686167e2fdce88433ec SHA512 3e1d5829689646d583da2eaaf3b8bbddec3cb4ca3dc3941ee2697f6367510a4dcff11984fa1792a400f49132778d7869f0a8274e42bc8c04f2e326e6a663c494
-EBUILD rosdep-0.19.0.ebuild 1512 BLAKE2B cc0c8275ebbd36624498d22e21707b3e806d3036b128c9861dc1fa38f417d8bfd52334fef993c50458123c7b49c209418ed35178e9cfc18f96f1a8f7ac318a40 SHA512 f8437f1b3f89d4d3aaa41f70d24cff1b2e6c8286b4d78fb55cb968b99dc603acd23ae9323c4f54c6f68bcebed9ddd10109a9462b7dde07f602a166e963039cf5
-EBUILD rosdep-9999.ebuild 1512 BLAKE2B cc0c8275ebbd36624498d22e21707b3e806d3036b128c9861dc1fa38f417d8bfd52334fef993c50458123c7b49c209418ed35178e9cfc18f96f1a8f7ac318a40 SHA512 f8437f1b3f89d4d3aaa41f70d24cff1b2e6c8286b4d78fb55cb968b99dc603acd23ae9323c4f54c6f68bcebed9ddd10109a9462b7dde07f602a166e963039cf5
+EBUILD rosdep-0.19.0-r1.ebuild 1624 BLAKE2B b02379abc8277ca2d293141b3376fe6f18110b43336d5bf6fa624b40b9efdceb6e709197bd7c60f01f0f510cf1338b0893472d93eda16d483126df7092494dfd SHA512 84a81ca80cfc28c72b5cd37208e3569d377e09ee9908416a32230b77cb730ee70fa8a30b2f8d9173062015d8b906385360d47dcc500937f0a3188b04e17ee87a
+EBUILD rosdep-9999.ebuild 1624 BLAKE2B b02379abc8277ca2d293141b3376fe6f18110b43336d5bf6fa624b40b9efdceb6e709197bd7c60f01f0f510cf1338b0893472d93eda16d483126df7092494dfd SHA512 84a81ca80cfc28c72b5cd37208e3569d377e09ee9908416a32230b77cb730ee70fa8a30b2f8d9173062015d8b906385360d47dcc500937f0a3188b04e17ee87a
MISC metadata.xml 339 BLAKE2B 98c570641ca07f96e5fcfaece9d49977136f720d77c9cf6dcecbb06bc4016410e082201d69d3c36af5de03cc70ea5a1b726289124324e2f11266e5db69a6ea97 SHA512 62ab4dc2638e4af95290eba19e1755d3bade56e5d1e7251d3cc9da410fcf7ead48562193b2cb6b6f8800daf7df31786e70ce153780b9e278891c31d2b9c257bf
diff --git a/dev-util/rosdep/files/tests.patch b/dev-util/rosdep/files/tests.patch
new file mode 100644
index 000000000000..cd6e199b3cd0
--- /dev/null
+++ b/dev-util/rosdep/files/tests.patch
@@ -0,0 +1,33 @@
+Index: rosdep-0.19.0/src/rosdep2/platforms/osx.py
+===================================================================
+--- rosdep-0.19.0.orig/src/rosdep2/platforms/osx.py
++++ rosdep-0.19.0/src/rosdep2/platforms/osx.py
+@@ -303,7 +303,7 @@ class HomebrewInstaller(PackageManagerIn
+
+ # make sure options is a list of list of strings
+ try:
+- valid = all([isinstance(x, _basestring) for l in options for x in l])
++ valid = all([isinstance(x, _basestring) for option in options for x in option])
+ except Exception as e:
+ raise InvalidData("Invalid list of options '%s', error: %s" % (options, e))
+ else:
+Index: rosdep-0.19.0/test/test_rosdep_gentoo.py
+===================================================================
+--- rosdep-0.19.0.orig/test/test_rosdep_gentoo.py
++++ rosdep-0.19.0/test/test_rosdep_gentoo.py
+@@ -183,13 +183,11 @@ def test_PortageInstaller():
+
+ mock_method.return_value = ['a', 'b']
+
+- expected = [['sudo', '-H', 'emerge', 'a'],
+- ['sudo', '-H', 'emerge', 'b']]
++ expected = [['sudo', '-H', 'emerge', 'a', 'b']]
+ val = installer.get_install_command(['whatever'], interactive=False)
+ assert val == expected, val
+
+- expected = [['sudo', '-H', 'emerge', '-a', 'a'],
+- ['sudo', '-H', 'emerge', '-a', 'b']]
++ expected = [['sudo', '-H', 'emerge', '-a', 'a', 'b']]
+ val = installer.get_install_command(['whatever'], interactive=True)
+ assert val == expected, val
+
diff --git a/dev-util/rosdep/rosdep-0.19.0.ebuild b/dev-util/rosdep/rosdep-0.19.0-r1.ebuild
index aa7a8d86538f..861de0006ff1 100644
--- a/dev-util/rosdep/rosdep-0.19.0.ebuild
+++ b/dev-util/rosdep/rosdep-0.19.0-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -38,14 +39,18 @@ DEPEND="${RDEPEND}"
BDEPEND="
dev-python/nose[${PYTHON_USEDEP}]
test? (
- dev-python/coverage[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/flake8[${PYTHON_USEDEP}]
)
"
+PATCHES=( "${FILESDIR}/tests.patch" )
python_test() {
- nosetests --with-coverage --cover-package=rosdep2 --with-xunit test || die
+ if has network-sandbox ${FEATURES}; then
+ einfo "Skipping tests due to network sandbox"
+ else
+ env -u ROS_DISTRO nosetests --with-xunit test || die
+ fi
}
pkg_postrm() {
diff --git a/dev-util/rosdep/rosdep-9999.ebuild b/dev-util/rosdep/rosdep-9999.ebuild
index aa7a8d86538f..861de0006ff1 100644
--- a/dev-util/rosdep/rosdep-9999.ebuild
+++ b/dev-util/rosdep/rosdep-9999.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -38,14 +39,18 @@ DEPEND="${RDEPEND}"
BDEPEND="
dev-python/nose[${PYTHON_USEDEP}]
test? (
- dev-python/coverage[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/flake8[${PYTHON_USEDEP}]
)
"
+PATCHES=( "${FILESDIR}/tests.patch" )
python_test() {
- nosetests --with-coverage --cover-package=rosdep2 --with-xunit test || die
+ if has network-sandbox ${FEATURES}; then
+ einfo "Skipping tests due to network sandbox"
+ else
+ env -u ROS_DISTRO nosetests --with-xunit test || die
+ fi
}
pkg_postrm() {