summaryrefslogtreecommitdiff
path: root/dev-util/rosdep
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/rosdep
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/rosdep')
-rw-r--r--dev-util/rosdep/Manifest6
-rw-r--r--dev-util/rosdep/metadata.xml11
-rw-r--r--dev-util/rosdep/rosdep-0.12.1.ebuild61
-rw-r--r--dev-util/rosdep/rosdep-0.12.2.ebuild61
-rw-r--r--dev-util/rosdep/rosdep-9999.ebuild61
5 files changed, 200 insertions, 0 deletions
diff --git a/dev-util/rosdep/Manifest b/dev-util/rosdep/Manifest
new file mode 100644
index 000000000000..6d24d1d6d670
--- /dev/null
+++ b/dev-util/rosdep/Manifest
@@ -0,0 +1,6 @@
+DIST rosdep-0.12.1.tar.gz 117102 BLAKE2B 42b0f6e7b6b0c2a4219bce24ff74ec01efb61ac0799a89baa5dc7f6b698e8f69a1578f744179252e7123c87c9fb0368b43a9a293609b28f6bfbc32c87b5f4627 SHA512 031bdfb4877865cacfab63a4494807ecf157d8514e89c7ab15e38fcbd4664df1247874975d7b1af42a8a1fc24cb62a558bd6b43732946f3122ffa6448a7631da
+DIST rosdep-0.12.2.tar.gz 118343 BLAKE2B 98163feef406707772a54bf6d1825900ac593113d635de92adcac0ae7ce201c2e312116104c76c13b9c1e3b1847ef4dcc0cfb4fd1edcb2795c6b323fa9cc7167 SHA512 0932a5ff9874bbdffa1160fe0a391d27eef9a2f2435d7a89fa3b5e4eab0fc08205d4417aaea1254ab7bfe679cfeb61a6f1b199f06d65154b30505e2a280c0b61
+EBUILD rosdep-0.12.1.ebuild 1493 BLAKE2B 14848d0cc919de003bdf86d87fcb942ca22aaa66b5c19eee08c288529682f152b0d25c542573261df6a18929dd54e7282df704c193e2f1bb8e9e3432d10ac418 SHA512 ec31c55b9e7c4de2b5eb7ebeec2b877fc10492324cbc46bb17961efde0fca52ad7be3f61559d845ea101afd9700fb01640b11b9ee30e32e07828b5bf4a1eab67
+EBUILD rosdep-0.12.2.ebuild 1493 BLAKE2B 14848d0cc919de003bdf86d87fcb942ca22aaa66b5c19eee08c288529682f152b0d25c542573261df6a18929dd54e7282df704c193e2f1bb8e9e3432d10ac418 SHA512 ec31c55b9e7c4de2b5eb7ebeec2b877fc10492324cbc46bb17961efde0fca52ad7be3f61559d845ea101afd9700fb01640b11b9ee30e32e07828b5bf4a1eab67
+EBUILD rosdep-9999.ebuild 1493 BLAKE2B 14848d0cc919de003bdf86d87fcb942ca22aaa66b5c19eee08c288529682f152b0d25c542573261df6a18929dd54e7282df704c193e2f1bb8e9e3432d10ac418 SHA512 ec31c55b9e7c4de2b5eb7ebeec2b877fc10492324cbc46bb17961efde0fca52ad7be3f61559d845ea101afd9700fb01640b11b9ee30e32e07828b5bf4a1eab67
+MISC metadata.xml 339 BLAKE2B 98c570641ca07f96e5fcfaece9d49977136f720d77c9cf6dcecbb06bc4016410e082201d69d3c36af5de03cc70ea5a1b726289124324e2f11266e5db69a6ea97 SHA512 62ab4dc2638e4af95290eba19e1755d3bade56e5d1e7251d3cc9da410fcf7ead48562193b2cb6b6f8800daf7df31786e70ce153780b9e278891c31d2b9c257bf
diff --git a/dev-util/rosdep/metadata.xml b/dev-util/rosdep/metadata.xml
new file mode 100644
index 000000000000..d067e076ce7f
--- /dev/null
+++ b/dev-util/rosdep/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-infrastructure/rosdep</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/rosdep/rosdep-0.12.1.ebuild b/dev-util/rosdep/rosdep-0.12.1.ebuild
new file mode 100644
index 000000000000..842ec4941e9e
--- /dev/null
+++ b/dev-util/rosdep/rosdep-0.12.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdep"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Command-line tool for installing ROS system dependencies"
+HOMEPAGE="http://wiki.ros.org/rosdep"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/ros-infrastructure/rosdep/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-coverage --cover-package=rosdep2 --with-xunit test || die
+}
+
+pkg_postrm() {
+ if [ "${ROOT:-/}" = "/" ] ; then
+ einfo "Removing rosdep default sources list."
+ rm -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list"
+ fi
+}
+
+pkg_postinst() {
+ if [ "${ROOT:-/}" = "/" -a ! -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list" ] ; then
+ einfo "Initializing rosdep"
+ rosdep init
+ fi
+}
diff --git a/dev-util/rosdep/rosdep-0.12.2.ebuild b/dev-util/rosdep/rosdep-0.12.2.ebuild
new file mode 100644
index 000000000000..842ec4941e9e
--- /dev/null
+++ b/dev-util/rosdep/rosdep-0.12.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdep"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Command-line tool for installing ROS system dependencies"
+HOMEPAGE="http://wiki.ros.org/rosdep"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/ros-infrastructure/rosdep/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-coverage --cover-package=rosdep2 --with-xunit test || die
+}
+
+pkg_postrm() {
+ if [ "${ROOT:-/}" = "/" ] ; then
+ einfo "Removing rosdep default sources list."
+ rm -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list"
+ fi
+}
+
+pkg_postinst() {
+ if [ "${ROOT:-/}" = "/" -a ! -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list" ] ; then
+ einfo "Initializing rosdep"
+ rosdep init
+ fi
+}
diff --git a/dev-util/rosdep/rosdep-9999.ebuild b/dev-util/rosdep/rosdep-9999.ebuild
new file mode 100644
index 000000000000..842ec4941e9e
--- /dev/null
+++ b/dev-util/rosdep/rosdep-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdep"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Command-line tool for installing ROS system dependencies"
+HOMEPAGE="http://wiki.ros.org/rosdep"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/ros-infrastructure/rosdep/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-coverage --cover-package=rosdep2 --with-xunit test || die
+}
+
+pkg_postrm() {
+ if [ "${ROOT:-/}" = "/" ] ; then
+ einfo "Removing rosdep default sources list."
+ rm -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list"
+ fi
+}
+
+pkg_postinst() {
+ if [ "${ROOT:-/}" = "/" -a ! -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list" ] ; then
+ einfo "Initializing rosdep"
+ rosdep init
+ fi
+}