summaryrefslogtreecommitdiff
path: root/dev-util/rosdep/rosdep-0.21.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
commita1b20429e7e2ba1b44414459afd5a2b50788cd9c (patch)
treee721db30ecc3e534a03ab9b3115762959cc0c28c /dev-util/rosdep/rosdep-0.21.0.ebuild
parentdbbd2ae5e62a232616ede4dae3ed69e15903940a (diff)
gentoo auto-resync : 25:01:2023 - 08:07:03
Diffstat (limited to 'dev-util/rosdep/rosdep-0.21.0.ebuild')
-rw-r--r--dev-util/rosdep/rosdep-0.21.0.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-util/rosdep/rosdep-0.21.0.ebuild b/dev-util/rosdep/rosdep-0.21.0.ebuild
deleted file mode 100644
index 8bfe26713410..000000000000
--- a/dev-util/rosdep/rosdep-0.21.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdep"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Command-line tool for installing ROS system dependencies"
-HOMEPAGE="https://wiki.ros.org/rosdep"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
-else
- SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
- https://github.com/ros-infrastructure/rosdep/archive/${PV}.tar.gz -> ${P}.tar.gz
- "
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-
-# Tests need network
-RESTRICT="test"
-PROPERTIES+=" test_network"
-
-RDEPEND="
- dev-python/catkin_pkg[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-python/rosdistro[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
- )
-"
-PATCHES=( "${FILESDIR}/tests.patch" )
-
-distutils_enable_tests pytest
-
-src_test() {
- unset ROS_DISTRO
- distutils-r1_src_test
-}
-
-pkg_postrm() {
- if [ "${ROOT:-/}" = "/" ] ; then
- einfo "Removing rosdep default sources list."
- rm -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list"
- fi
-}
-
-pkg_postinst() {
- if [ "${ROOT:-/}" = "/" -a ! -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list" ] ; then
- einfo "Initializing rosdep"
- rosdep init
- fi
-}