summaryrefslogtreecommitdiff
path: root/dev-util/rosdep/rosdep-0.20.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-util/rosdep/rosdep-0.20.0.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-util/rosdep/rosdep-0.20.0.ebuild')
-rw-r--r--dev-util/rosdep/rosdep-0.20.0.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/dev-util/rosdep/rosdep-0.20.0.ebuild b/dev-util/rosdep/rosdep-0.20.0.ebuild
deleted file mode 100644
index dde1899da88c..000000000000
--- a/dev-util/rosdep/rosdep-0.20.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdep"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Command-line tool for installing ROS system dependencies"
-HOMEPAGE="https://wiki.ros.org/rosdep"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
-else
- SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
- https://github.com/ros-infrastructure/rosdep/archive/${PV}.tar.gz -> ${P}.tar.gz
- "
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/catkin_pkg[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-python/rosdistro[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-python/nose[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
- )
-"
-PATCHES=( "${FILESDIR}/tests.patch" )
-
-python_test() {
- if has network-sandbox ${FEATURES}; then
- einfo "Skipping tests due to network sandbox"
- else
- env -u ROS_DISTRO nosetests --with-xunit test || die
- fi
-}
-
-pkg_postrm() {
- if [ "${ROOT:-/}" = "/" ] ; then
- einfo "Removing rosdep default sources list."
- rm -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list"
- fi
-}
-
-pkg_postinst() {
- if [ "${ROOT:-/}" = "/" -a ! -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list" ] ; then
- einfo "Initializing rosdep"
- rosdep init
- fi
-}