summaryrefslogtreecommitdiff
path: root/dev-util/ropper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-util/ropper
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-util/ropper')
-rw-r--r--dev-util/ropper/Manifest4
-rw-r--r--dev-util/ropper/metadata.xml23
-rw-r--r--dev-util/ropper/ropper-1.13.6.ebuild46
-rw-r--r--dev-util/ropper/ropper-9999.ebuild46
4 files changed, 119 insertions, 0 deletions
diff --git a/dev-util/ropper/Manifest b/dev-util/ropper/Manifest
new file mode 100644
index 000000000000..038309e185ba
--- /dev/null
+++ b/dev-util/ropper/Manifest
@@ -0,0 +1,4 @@
+DIST ropper-1.13.6.tar.gz 1491005 BLAKE2B aa82c9791eec2362c79f3cd96995cb505b73c8131b0b6fe6a7d0932e3551dd15ea401383e12ab79901ea05e749cb2ca8244fa3c909e0e8955910d321c8436ea9 SHA512 c3e20bc7182a94984f50c42334a7af1e64bd564615a3aaaa08f432b0641a9557d27fd19bdb6c33a276d66c4b512534c625751e20531c324bde96a58d9c89b6d4
+EBUILD ropper-1.13.6.ebuild 1102 BLAKE2B e52ef8a6bc3a1aa70d72d0b5d1b172312cc943ac029ab53281afe52d72bc2c9666fccdaf06a4475b5811e2114cde8b8d8c800168e137e7757240c26b891f3132 SHA512 e8302bfe62bb3c97bc1260537b4c2561d2d18e21832e81cab4693a1870e614cb74a4bc9a81e3af2eb6010ddfd66690c95a9fd052b278e47c4825cbbb8a8daf04
+EBUILD ropper-9999.ebuild 1102 BLAKE2B e52ef8a6bc3a1aa70d72d0b5d1b172312cc943ac029ab53281afe52d72bc2c9666fccdaf06a4475b5811e2114cde8b8d8c800168e137e7757240c26b891f3132 SHA512 e8302bfe62bb3c97bc1260537b4c2561d2d18e21832e81cab4693a1870e614cb74a4bc9a81e3af2eb6010ddfd66690c95a9fd052b278e47c4825cbbb8a8daf04
+MISC metadata.xml 742 BLAKE2B b5f76f0022f4e73f749cc26c4302d940b598d96352a9bd5ff783d5c7bbbe937f13c16d5d0fbbd794e63d19b7299cefd7321dc13277b5ee615666f4d074ae28bc SHA512 ddb1ea4d6594260ddc0b8865b3d667f1a484c8014c98b13b89c47609e141ca327c8bf2679c95dc6c5634a3e7dbe65a0260b4efb7ea32950d3bef2cbbdd6b4de9
diff --git a/dev-util/ropper/metadata.xml b/dev-util/ropper/metadata.xml
new file mode 100644
index 000000000000..a1652b1a8756
--- /dev/null
+++ b/dev-util/ropper/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <longdescription>
+ You can use ropper to display information about binary files in
+ different file formats and you can search for gadgets to build rop
+ chains for different architectures.
+ </longdescription>
+ <use>
+ <flag name="z3">Enable Z3 contraint solver support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">sashs/Ropper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/ropper/ropper-1.13.6.ebuild b/dev-util/ropper/ropper-1.13.6.ebuild
new file mode 100644
index 000000000000..6bd50c5a169b
--- /dev/null
+++ b/dev-util/ropper/ropper-1.13.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use to display information about binary files in different file formats"
+HOMEPAGE="https://scoding.de/ropper https://github.com/sashs/Ropper"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sashs/Ropper"
+else
+ SRC_URI="https://github.com/sashs/Ropper/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/Ropper-${PV}
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="z3"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/capstone[python,${PYTHON_USEDEP}]
+ dev-libs/keystone[python,${PYTHON_USEDEP}]
+ dev-python/filebytes[${PYTHON_USEDEP}]
+ ')
+ z3? ( sci-mathematics/z3[python,${PYTHON_SINGLE_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Remove test which dies on trying to import itself (stub loader, not a real test)
+ rm test.py || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-util/ropper/ropper-9999.ebuild b/dev-util/ropper/ropper-9999.ebuild
new file mode 100644
index 000000000000..6bd50c5a169b
--- /dev/null
+++ b/dev-util/ropper/ropper-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use to display information about binary files in different file formats"
+HOMEPAGE="https://scoding.de/ropper https://github.com/sashs/Ropper"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sashs/Ropper"
+else
+ SRC_URI="https://github.com/sashs/Ropper/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/Ropper-${PV}
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="z3"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/capstone[python,${PYTHON_USEDEP}]
+ dev-libs/keystone[python,${PYTHON_USEDEP}]
+ dev-python/filebytes[${PYTHON_USEDEP}]
+ ')
+ z3? ( sci-mathematics/z3[python,${PYTHON_SINGLE_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Remove test which dies on trying to import itself (stub loader, not a real test)
+ rm test.py || die
+
+ distutils-r1_src_prepare
+}