summaryrefslogtreecommitdiff
path: root/dev-util/rizin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-util/rizin
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-util/rizin')
-rw-r--r--dev-util/rizin/Manifest1
-rw-r--r--dev-util/rizin/rizin-0.3.4-r1.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-util/rizin/Manifest b/dev-util/rizin/Manifest
index 2b96b1ffbc77..3c00397fcef4 100644
--- a/dev-util/rizin/Manifest
+++ b/dev-util/rizin/Manifest
@@ -2,5 +2,6 @@ AUX rizin-0.3.0-typedb-prefix.patch 5175 BLAKE2B 08fea1ba6297f17d42f518c1739875c
AUX rizin-0.3.2-never-rebuild-parser.patch 1493 BLAKE2B fd5a4d306336ccba939e9d96e97d4b653b83407352f9babf9c39bbad28a18b4fc1a3e2f1eb57b25b7f8dad35b3400271cf6a6bf1cec55c74dc00f424da715c91 SHA512 7a105831cbdb99633c43411b7a407ff6970cb8e89cae561886ade96c75579c0484271641e957762189fc68762952a26ca0a2536bd1342802c408041066852b16
DIST rizin-src-v0.3.4.tar.xz 10411432 BLAKE2B 99745f069e6bd72aec6a6f335f3aa0ccc46ebf186b1dc0aaf32b4f95d2be4bb49e8d3d976a72978c22fce82d896e70bf8403568e100b73898731045ef06a2ad5 SHA512 cda35afe8c031f3207c055ed31d7f76a46b7addd04cead0f5aadf0733b66f4dd953ca16f054b47da7921d4726d6ea1250436012954a9755c1cd524a8fd0d670c
DIST rizin-testbins-aa6a88dcdfaad54335e3935c16ce21a124ff861d.tar.gz 127254454 BLAKE2B e7a4536be7169abd197c2128e103b8d669fbb7532ce265b27da3ce347b1aa58c8a96c95d85cf7700f66a44c041a0575175de3a0e176a0d31c490f7ccfb2f6d6b SHA512 20cf299e5324793f07f8a2fdcfa3d66c3a418f09bfc6a272e35ab31d4a64408bf91532ae431098dede1a2d0ad0b1c02433304c514816d98dc068f6c0528a4099
+EBUILD rizin-0.3.4-r1.ebuild 2949 BLAKE2B a9bc52204a78067073435df92cfafa1e8c41757c6aa78782ee2914e02c859588fcad8eeed5c2d8f75d72e69a418eef40831f80b671069b9b7f407737ae0394eb SHA512 29fe2634d5a6677de17932b0f5dcf1018acb835a92ba9ed6c96e15be740e9534b730045bbbfbabda62b89bfc2d8efcb6a64d78fdf6f1863c39570bcc9f50e042
EBUILD rizin-0.3.4.ebuild 2945 BLAKE2B 9fa83d7ac4b5fc25886439e34cccf2c378dad4d18ffdd098f2fb02732a13ae4304fad5dffc5f9d92ec898b020900aa53e7d09a8ee93a3b2189d47461b9c01344 SHA512 83d5364a7b2a4f92730e3cebe5e5443ea7086fb8e616dfaf4dff3c4755ef35f1e4a40adce4a0b829110e27799a7ea97799809c1bb396c1ff618a57b769aa0f8a
MISC metadata.xml 348 BLAKE2B eea14d9f2e713f2f272a46bd754e500b28ec3958f0f4295e6fe6e73c9dcfa1e180fa62901bdb591fdb43ec8ead23a63f20416e52605e6ae186532e651e0eb1a3 SHA512 db41ccd0ce1493387c47eb707dd303c556ad784ffab2ffe03509a4ff7b0c1b650b0f0999edb5e4e040f95f1f550e9a11ead273ec74ebedb97e645e40c6ad37d5
diff --git a/dev-util/rizin/rizin-0.3.4-r1.ebuild b/dev-util/rizin/rizin-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..cc3e0fb5efbd
--- /dev/null
+++ b/dev-util/rizin/rizin-0.3.4-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+# This is the commit that the CI for the release commit used
+BINS_COMMIT="aa6a88dcdfaad54335e3935c16ce21a124ff861d"
+
+inherit meson python-any-r1
+
+DESCRIPTION="reverse engineering framework for binary analysis"
+HOMEPAGE="https://rizin.re/"
+
+SRC_URI="mirror+https://github.com/rizinorg/rizin/releases/download/v${PV}/rizin-src-v${PV}.tar.xz
+ test? ( https://github.com/rizinorg/rizin-testbins/archive/${BINS_COMMIT}.tar.gz -> rizin-testbins-${BINS_COMMIT}.tar.gz )"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+LICENSE="Apache-2.0 BSD LGPL-3 MIT"
+SLOT="0/${PV}"
+IUSE="test"
+
+# Need to audit licenses of the binaries used for testing
+RESTRICT="fetch !test? ( test )"
+
+RDEPEND="
+ sys-apps/file
+ app-arch/lz4:0=
+ <dev-libs/capstone-5:0=
+ dev-libs/libuv:0=
+ dev-libs/libzip:0=
+ dev-libs/openssl:0=
+ >=dev-libs/tree-sitter-0.19.0
+ dev-libs/xxhash
+ sys-libs/zlib:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.0-typedb-prefix.patch"
+ "${FILESDIR}/${PN}-0.3.2-never-rebuild-parser.patch"
+)
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_prepare() {
+ default
+
+ local py_to_mangle=(
+ librz/core/cmd_descs/cmd_descs_generate.py
+ subprojects/lz4-1.9.3/contrib/meson/meson/GetLz4LibraryVersion.py
+ subprojects/lz4-1.9.3/contrib/meson/meson/InstallSymlink.py
+ subprojects/lz4-1.9.3/tests/test-lz4-list.py
+ subprojects/lz4-1.9.3/tests/test-lz4-speed.py
+ subprojects/lz4-1.9.3/tests/test-lz4-versions.py
+ sys/clang-format.py
+ test/fuzz/scripts/fuzz_rz_asm.py
+ test/scripts/gdbserver.py
+ )
+
+ python_fix_shebang "${py_to_mangle[@]}"
+
+ if use test; then
+ cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}/test/bins" || die
+ cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}" || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dcli=enabled
+ -Duse_sys_capstone=enabled
+ -Duse_sys_magic=enabled
+ -Duse_sys_libzip=enabled
+ -Duse_sys_zlib=enabled
+ -Duse_sys_lz4=enabled
+ -Duse_sys_xxhash=enabled
+ -Duse_sys_openssl=enabled
+ -Duse_sys_tree_sitter=enabled
+
+ $(meson_use test enable_tests)
+ $(meson_use test enable_rz_test)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # Rizin uses data files that it expects to be installed on the
+ # system. To hack around this, we create a tree of what it expects
+ # in ${T}, and patch the tests to support a prefix from the
+ # environment. https://github.com/rizinorg/rizin/issues/1789
+ mkdir -p "${T}/usr/share/${PN}/${PV}" || die
+ ln -sf "${BUILD_DIR}/librz/analysis/d" "${T}/usr/share/${PN}/${PV}/types" || die
+ ln -sf "${BUILD_DIR}/librz/syscall/d" "${T}/usr/share/${PN}/${PV}/syscall" || die
+ ln -sf "${BUILD_DIR}/librz/asm/d" "${T}/usr/share/${PN}/${PV}/opcodes" || die
+ # https://github.com/rizinorg/rizin/issues/1797
+ ln -sf "${BUILD_DIR}/librz/flag/d" "${T}/usr/share/${PN}/${PV}/flag" || die
+ export RZ_PREFIX="${T}/usr"
+
+ meson_src_test
+}