summaryrefslogtreecommitdiff
path: root/dev-util/reuse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-20 01:53:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-20 01:53:29 +0000
commit54d0ccbac3b6fbd01dcd252ea006d4e9e62f8e6e (patch)
treefc8f42b6568c9de11a72455118288dee202ce586 /dev-util/reuse
parent3f0a9aff8dc766c410952343d02561aab3eda2b9 (diff)
gentoo auto-resync : 20:12:2023 - 01:53:29
Diffstat (limited to 'dev-util/reuse')
-rw-r--r--dev-util/reuse/Manifest4
-rw-r--r--dev-util/reuse/files/reuse-2.1.0_docs.patch15
-rw-r--r--dev-util/reuse/metadata.xml13
-rw-r--r--dev-util/reuse/reuse-2.1.0.ebuild50
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-util/reuse/Manifest b/dev-util/reuse/Manifest
new file mode 100644
index 000000000000..088dad71faae
--- /dev/null
+++ b/dev-util/reuse/Manifest
@@ -0,0 +1,4 @@
+AUX reuse-2.1.0_docs.patch 476 BLAKE2B 4ce92fdef2292a21c1cdc31a1d2990156f3a523fe461894caeca616291a14e59ccd271bcbf9c026c616e7fb6bcc90ed36b34d192f00e5ddd4881b8710fe918b6 SHA512 e0be3de775e0fa9dccdc4987c7c0edb2f58e9bf9886cdd1e16d02226f30d8d878ac7a7029daefbc5650eb00aff489a70f1af1882e36932ad713cfa6c680dabd3
+DIST reuse-2.1.0.gh.tar.gz 260786 BLAKE2B 371c1167e10449ecdbaf0a93dbfa7d50c700daaf71394379a48d1baaae0b1be03728e79fd551da75a3743e06cae1a77e7445482222845d1356a6af3eb39bef46 SHA512 912d713b2c68029cc67a5fbebfca61d96165ae8ae9d927bbdd651cf2130104b297d5c0133f1a46442cba3ec84d00ba92c27414bff770d2250f5a2131c7ad4aef
+EBUILD reuse-2.1.0.ebuild 1376 BLAKE2B 85b2d01de304023e291b1ff4372e6cfb8b7312f983389fc9db52dd079a79a04a291fe49773318c13687febb110c91c2e8ac38d076834502cbb91513165c4408a SHA512 d8a2c80bcfa1b720df5fdc752d430676b87ffab1d5aac8849889ad08abe3dae73a3b1cc6bd8c198c8f9612a545725e90168347d65380ecb490ba05184783873d
+MISC metadata.xml 411 BLAKE2B d0d872754355df68caf5156db9169200894db1ab16c8666339718c170b79320b11e11f68481052b9fafbe5090faa2391ea5035164e41171beecf61801a1e3cef SHA512 dc02d799db0c9614ce3db149a400731fe9239b1f691de7b7bbf7b5c9d056bc5f8ecf45e4797246b68df645838e03b22d3a5d5e0f34b61a407fe7cd1f668c2aed
diff --git a/dev-util/reuse/files/reuse-2.1.0_docs.patch b/dev-util/reuse/files/reuse-2.1.0_docs.patch
new file mode 100644
index 000000000000..a9f19a8ea0a4
--- /dev/null
+++ b/dev-util/reuse/files/reuse-2.1.0_docs.patch
@@ -0,0 +1,15 @@
+--- a/docs/conf.py
++++ b/docs/conf.py
+@@ -189,9 +189,9 @@
+ """Copy the markdown files from the root of the project into the docs/
+ directory.
+ """
+- copyfile("../README.md", "readme.md")
+- copyfile("../CHANGELOG.md", "history.md")
+- copyfile("../CONTRIBUTING.md", "contributing.md")
++ copyfile("README.md", "docs/readme.md")
++ copyfile("CHANGELOG.md", "docs/history.md")
++ copyfile("CONTRIBUTING.md", "docs/contributing.md")
+
+
+ def setup(app):
diff --git a/dev-util/reuse/metadata.xml b/dev-util/reuse/metadata.xml
new file mode 100644
index 000000000000..22d7a2c8d2d4
--- /dev/null
+++ b/dev-util/reuse/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jstein@gentoo.org</email>
+ <name>Jonas Stein</name>
+ </maintainer>
+ <upstream>
+ <doc>https://reuse.readthedocs.io/</doc>
+ <remote-id type="pypi">reuse</remote-id>
+ <remote-id type="github">fsfe/reuse-tool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/reuse/reuse-2.1.0.ebuild b/dev-util/reuse/reuse-2.1.0.ebuild
new file mode 100644
index 000000000000..097ea77f1667
--- /dev/null
+++ b/dev-util/reuse/reuse-2.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Manage license information according to the SPDX standard"
+HOMEPAGE="https://reuse.software/
+ https://github.com/fsfe/reuse-tool"
+MY_PN="${PN}-tool"
+SRC_URI="https://github.com/fsfe/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0 CC0-1.0 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/binaryornot-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/boolean-py-3.8[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/license-expression-1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-debian-0.1.48[${PYTHON_USEDEP}]"
+
+BDEPEND="sys-devel/gettext
+ test? (
+ dev-vcs/git
+ dev-vcs/mercurial
+ )"
+
+PATCHES=( "${FILESDIR}/reuse-2.1.0_docs.patch" )
+
+DOCS=( AUTHORS.rst CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md README.md )
+
+distutils_enable_tests pytest
+
+# dev-python/sphinx-autodoc-typehints will be dropped after 2.1.0
+distutils_enable_sphinx docs \
+ ">=dev-python/furo-2023.3.27" \
+ ">=dev-python/recommonmark-0.7.1" \
+ ">=dev-python/sphinxcontrib-apidoc-0.3.0" \
+ ">=dev-python/sphinx-autodoc-typehints-1.12.0"
+
+python_test() {
+ cd "${T}" || die
+ epytest "${S}"/tests
+}