summaryrefslogtreecommitdiff
path: root/dev-util/repolite/repolite-0.2.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-27 14:54:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-27 14:54:15 +0100
commitd654bb059f90c086625a31ce15747f8418cd4bd5 (patch)
tree0a78e925021da9dc8bfd06ada53004c160b957b3 /dev-util/repolite/repolite-0.2.0-r2.ebuild
parent4e6378ddac49b7268b7ab55d1f5900b2a6d81923 (diff)
gentoo auto-resync : 27:08:2022 - 14:54:15
Diffstat (limited to 'dev-util/repolite/repolite-0.2.0-r2.ebuild')
-rw-r--r--dev-util/repolite/repolite-0.2.0-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/repolite/repolite-0.2.0-r2.ebuild b/dev-util/repolite/repolite-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..38159f7e9aa9
--- /dev/null
+++ b/dev-util/repolite/repolite-0.2.0-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manage a small set of git repository dependencies with YAML."
+HOMEPAGE="https://github.com/sarnold/repolite"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/sarnold/repolite.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sarnold/repolite/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+RESTRICT="test" # no tests :(
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/munch[${PYTHON_USEDEP}]
+ dev-vcs/git
+"
+BDEPEND="
+ $(python_gen_any_dep '
+ >=dev-python/versioningit-2.0.1[${PYTHON_USEDEP}]
+ ')
+"
+
+DOCS=( README.rst )
+
+distutils_enable_sphinx \
+ docs/source \
+ dev-python/sphinx_rtd_theme \
+ dev-python/recommonmark \
+ dev-python/sphinxcontrib-apidoc
+
+pkg_postinst() {
+ optfeature "initialize repos with lfs files" dev-vcs/git-lfs
+}