summaryrefslogtreecommitdiff
path: root/dev-util/rebar/rebar-2.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/rebar/rebar-2.6.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/rebar/rebar-2.6.1.ebuild')
-rw-r--r--dev-util/rebar/rebar-2.6.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/rebar/rebar-2.6.1.ebuild b/dev-util/rebar/rebar-2.6.1.ebuild
new file mode 100644
index 000000000000..3ca90ef6ba83
--- /dev/null
+++ b/dev-util/rebar/rebar-2.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://github.com/rebar/rebar"
+SRC_URI="https://github.com/rebar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ppc ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND="dev-lang/erlang"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ emake xref
+}
+
+src_install() {
+ dobin rebar
+ dodoc rebar.config.sample THANKS
+ dobashcomp priv/shell-completion/bash/${PN}
+}