summaryrefslogtreecommitdiff
path: root/dev-util/rats/rats-2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/rats/rats-2.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/rats/rats-2.4.ebuild')
-rw-r--r--dev-util/rats/rats-2.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/rats/rats-2.4.ebuild b/dev-util/rats/rats-2.4.ebuild
new file mode 100644
index 000000000000..1c49b7c4df49
--- /dev/null
+++ b/dev-util/rats/rats-2.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+inherit eutils
+
+DESCRIPTION="RATS - Rough Auditing Tool for Security"
+HOMEPAGE="https://code.google.com/p/rough-auditing-tool-for-security/"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/rough-auditing-tool-for-security/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-libs/expat"
+
+src_prepare() {
+ edos2unix $(find "${S}" -name '*.[chl]' -o -name '*.in' -o -name '*.am')
+ #epatch "${FILESDIR}"/${PN}-2.1-add-getopt-trailing-null.patch
+ #epatch "${FILESDIR}"/${PN}-2.1-fix-null-pointers.patch
+}
+
+src_configure() {
+ econf --datadir="${EPREFIX}/usr/share/${PN}/"
+}
+
+src_install () {
+ einstall SHAREDIR="${ED}/usr/share/${PN}" MANDIR="${ED}/usr/share/man"
+ dodoc README README.win32
+}
+
+pkg_postinst() {
+ ewarn "Please be careful when using this program with it's force language"
+ ewarn "option, '--language <LANG>' it may take huge amounts of memory when"
+ ewarn "it tries to treat binary files as some other type."
+}