summaryrefslogtreecommitdiff
path: root/dev-util/rats/rats-2.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-25 07:12:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-25 07:12:05 +0000
commit14a74a5f982f25582974c2ee235027a041aec36d (patch)
treedc57c37e535d9d67af9a5034c4748ec3698923b9 /dev-util/rats/rats-2.4-r2.ebuild
parentb1b0997aac1e7f68389ed3e0f95d3ea9d92277e2 (diff)
gentoo auto-resync : 25:11:2022 - 07:12:04
Diffstat (limited to 'dev-util/rats/rats-2.4-r2.ebuild')
-rw-r--r--dev-util/rats/rats-2.4-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/rats/rats-2.4-r2.ebuild b/dev-util/rats/rats-2.4-r2.ebuild
new file mode 100644
index 000000000000..6e50805b79bd
--- /dev/null
+++ b/dev-util/rats/rats-2.4-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools edos2unix
+
+DESCRIPTION="RATS - Rough Auditing Tool for Security"
+HOMEPAGE="https://github.com/andrew-d/rough-auditing-tool-for-security"
+# No tags available in the GitHub port
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/rough-auditing-tool-for-security/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="dev-libs/expat:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.4-fix-build-system.patch )
+
+src_prepare() {
+ default
+
+ local f
+ while IFS="" read -d $'\0' -r f; do
+ einfo "Converting ${f} from CRLF to LF"
+ edos2unix "${f}"
+ done < <(find \( -name '*.[chl]' -o -name '*.in' -o -name '*.am' \) -print0)
+
+ # Clang 16
+ eautoreconf
+}
+
+src_configure() {
+ econf --datadir="${EPREFIX}/usr/share/${PN}/"
+}
+
+pkg_postinst() {
+ ewarn "Please be careful when using this program with it's force language"
+ ewarn "option, '--language <LANG>' it may take huge amounts of memory when"
+ ewarn "it tries to treat binary files as some other type."
+}