summaryrefslogtreecommitdiff
path: root/dev-util/ragel/ragel-7.0.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/ragel/ragel-7.0.0.10.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/ragel/ragel-7.0.0.10.ebuild')
-rw-r--r--dev-util/ragel/ragel-7.0.0.10.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/ragel/ragel-7.0.0.10.ebuild b/dev-util/ragel/ragel-7.0.0.10.ebuild
new file mode 100644
index 000000000000..e9215b2485be
--- /dev/null
+++ b/dev-util/ragel/ragel-7.0.0.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Compiles finite state machines from regular languages into executable code"
+HOMEPAGE="https://www.colm.net/open-source/ragel/"
+SRC_URI="https://www.colm.net/files/ragel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86"
+IUSE="vim-syntax"
+
+DEPEND="~dev-util/colm-0.13.0.5"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ cd "${S}"/test || die
+ ./runtests.in || die
+}
+
+src_install() {
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ragel.vim
+ fi
+ default
+}