summaryrefslogtreecommitdiff
path: root/dev-util/ragel/ragel-7.0.0.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
commit51536d2fe4697ba9114d611178bb9e20d3d5b729 (patch)
tree30b91d98e65985a575940ed49e756697c1f049c2 /dev-util/ragel/ragel-7.0.0.10-r1.ebuild
parent4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (diff)
gentoo resync : 23.12.2017
Diffstat (limited to 'dev-util/ragel/ragel-7.0.0.10-r1.ebuild')
-rw-r--r--dev-util/ragel/ragel-7.0.0.10-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/ragel/ragel-7.0.0.10-r1.ebuild b/dev-util/ragel/ragel-7.0.0.10-r1.ebuild
new file mode 100644
index 000000000000..5c8640303fd5
--- /dev/null
+++ b/dev-util/ragel/ragel-7.0.0.10-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Compiles finite state machines from regular languages into executable code"
+HOMEPAGE="https://www.colm.net/open-source/ragel/"
+SRC_URI="https://www.colm.net/files/ragel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86"
+IUSE="vim-syntax"
+
+DEPEND="~dev-util/colm-0.13.0.5"
+RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-use-pkginclude.patch" )
+
+src_test() {
+ cd "${S}"/test || die
+ ./runtests.in || die
+}
+
+src_install() {
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ragel.vim
+ fi
+ default
+}