summaryrefslogtreecommitdiff
path: root/dev-util/ragel/ragel-6.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/ragel/ragel-6.9.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/ragel/ragel-6.9.ebuild')
-rw-r--r--dev-util/ragel/ragel-6.9.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/ragel/ragel-6.9.ebuild b/dev-util/ragel/ragel-6.9.ebuild
new file mode 100644
index 000000000000..9de48f66793e
--- /dev/null
+++ b/dev-util/ragel/ragel-6.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils autotools autotools-utils
+
+DESCRIPTION="Compiles finite state machines from regular languages into executable code"
+HOMEPAGE="http://www.colm.net/open-source/ragel/"
+SRC_URI="http://www.colm.net/files/ragel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND=""
+
+# We need to get the txl language in Portage to have the tests :(
+RESTRICT=test
+
+PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
+DOCS=( ChangeLog CREDITS README TODO )
+
+src_test() {
+ cd "${S}"/test
+ ./runtests.in || die
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ragel.vim
+ fi
+}