summaryrefslogtreecommitdiff
path: root/dev-util/ragel/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-util/ragel/files
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/ragel/files')
-rw-r--r--dev-util/ragel/files/ragel-6.7+gcc-4.7.patch178
-rw-r--r--dev-util/ragel/files/ragel-6.7-cross-compile.patch21
-rw-r--r--dev-util/ragel/files/ragel-6.9-gcc6.patch42
-rw-r--r--dev-util/ragel/files/ragel-7.0.0.10-use-pkginclude.patch41
4 files changed, 0 insertions, 282 deletions
diff --git a/dev-util/ragel/files/ragel-6.7+gcc-4.7.patch b/dev-util/ragel/files/ragel-6.7+gcc-4.7.patch
deleted file mode 100644
index 80eb29a46f05..000000000000
--- a/dev-util/ragel/files/ragel-6.7+gcc-4.7.patch
+++ /dev/null
@@ -1,178 +0,0 @@
-From 27454d1e55b2a5cefc3cc1044d036add9ee9a6d3 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Diego=20Elio=20Petten=C3=B2?= <flameeyes@flameeyes.eu>
-Date: Tue, 22 May 2012 16:25:37 -0700
-Subject: [PATCH] aapl: fix building with gcc-4.7.0
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Starting with GCC 4.7, you have to explicit methods inherited from
-base templates, otherwise it will refuse to build.
-
----
-
-The URL reported in the README is no longer registered, so I couldn't
-find a way to report this to an upstream project.
-
-Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
----
- aapl/avlcommon.h | 12 ++++++------
- aapl/bstcommon.h | 16 ++++++++--------
- aapl/bubblesort.h | 2 +-
- aapl/mergesort.h | 2 +-
- 4 files changed, 16 insertions(+), 16 deletions(-)
-
-diff --git a/aapl/avlcommon.h b/aapl/avlcommon.h
-index 06983bc..2e3c190 100644
---- a/aapl/avlcommon.h
-+++ b/aapl/avlcommon.h
-@@ -881,9 +881,9 @@ template <AVLMEL_TEMPDEF> Element *AvlTree<AVLMEL_TEMPUSE>::
- }
-
- #ifdef AVL_BASIC
-- keyRelation = compare( *element, *curEl );
-+ keyRelation = this->compare( *element, *curEl );
- #else
-- keyRelation = compare( element->BASEKEY(getKey()),
-+ keyRelation = this->compare( element->BASEKEY(getKey()),
- curEl->BASEKEY(getKey()) );
- #endif
-
-@@ -920,7 +920,7 @@ template <AVLMEL_TEMPDEF> Element *AvlTree<AVLMEL_TEMPUSE>::
- long keyRelation;
-
- while (curEl) {
-- keyRelation = compare( *element, *curEl );
-+ keyRelation = this->compare( *element, *curEl );
-
- /* Do we go left? */
- if ( keyRelation < 0 )
-@@ -969,7 +969,7 @@ template <AVLMEL_TEMPDEF> Element *AvlTree<AVLMEL_TEMPUSE>::
- return element;
- }
-
-- keyRelation = compare( key, curEl->BASEKEY(getKey()) );
-+ keyRelation = this->compare( key, curEl->BASEKEY(getKey()) );
-
- /* Do we go left? */
- if ( keyRelation < 0 ) {
-@@ -1023,7 +1023,7 @@ template <AVLMEL_TEMPDEF> Element *AvlTree<AVLMEL_TEMPUSE>::
- return element;
- }
-
-- keyRelation = compare(key, curEl->getKey());
-+ keyRelation = this->compare(key, curEl->getKey());
-
- /* Do we go left? */
- if ( keyRelation < 0 ) {
-@@ -1058,7 +1058,7 @@ template <AVLMEL_TEMPDEF> Element *AvlTree<AVLMEL_TEMPUSE>::
- long keyRelation;
-
- while (curEl) {
-- keyRelation = compare( key, curEl->BASEKEY(getKey()) );
-+ keyRelation = this->compare( key, curEl->BASEKEY(getKey()) );
-
- /* Do we go left? */
- if ( keyRelation < 0 )
-diff --git a/aapl/bstcommon.h b/aapl/bstcommon.h
-index 888717f..7c53ff3 100644
---- a/aapl/bstcommon.h
-+++ b/aapl/bstcommon.h
-@@ -361,7 +361,7 @@ template <BST_TEMPL_DEF> bool BstTable<BST_TEMPL_USE>::
- }
-
- mid = lower + ((upper-lower)>>1);
-- keyRelation = compare(key, GET_KEY(*mid));
-+ keyRelation = this->compare(key, GET_KEY(*mid));
-
- if ( keyRelation < 0 )
- upper = mid - 1;
-@@ -373,12 +373,12 @@ template <BST_TEMPL_DEF> bool BstTable<BST_TEMPL_USE>::
-
- lower = mid - 1;
- while ( lower != lowEnd &&
-- compare(key, GET_KEY(*lower)) == 0 )
-+ this->compare(key, GET_KEY(*lower)) == 0 )
- lower--;
-
- upper = mid + 1;
- while ( upper != highEnd &&
-- compare(key, GET_KEY(*upper)) == 0 )
-+ this->compare(key, GET_KEY(*upper)) == 0 )
- upper++;
-
- low = (Element*)lower + 1;
-@@ -419,7 +419,7 @@ template <BST_TEMPL_DEF> Element *BstTable<BST_TEMPL_USE>::
- }
-
- mid = lower + ((upper-lower)>>1);
-- keyRelation = compare(key, GET_KEY(*mid));
-+ keyRelation = this->compare(key, GET_KEY(*mid));
-
- if ( keyRelation < 0 )
- upper = mid - 1;
-@@ -457,7 +457,7 @@ template <BST_TEMPL_DEF> Element *BstTable<BST_TEMPL_USE>::
- }
-
- mid = lower + ((upper-lower)>>1);
-- keyRelation = compare(key, GET_KEY(*mid));
-+ keyRelation = this->compare(key, GET_KEY(*mid));
-
- if ( keyRelation < 0 )
- upper = mid - 1;
-@@ -508,7 +508,7 @@ template <BST_TEMPL_DEF> Element *BstTable<BST_TEMPL_USE>::
- }
-
- mid = lower + ((upper-lower)>>1);
-- keyRelation = compare(key, GET_KEY(*mid));
-+ keyRelation = this->compare(key, GET_KEY(*mid));
-
- if ( keyRelation < 0 )
- upper = mid - 1;
-@@ -603,7 +603,7 @@ template <BST_TEMPL_DEF> Element *BstTable<BST_TEMPL_USE>::
- }
-
- mid = lower + ((upper-lower)>>1);
-- keyRelation = compare(GET_KEY(el), GET_KEY(*mid));
-+ keyRelation = this->compare(GET_KEY(el), GET_KEY(*mid));
-
- if ( keyRelation < 0 )
- upper = mid - 1;
-@@ -662,7 +662,7 @@ template <BST_TEMPL_DEF> Element *BstTable<BST_TEMPL_USE>::
- }
-
- mid = lower + ((upper-lower)>>1);
-- keyRelation = compare(GET_KEY(el), GET_KEY(*mid));
-+ keyRelation = this->compare(GET_KEY(el), GET_KEY(*mid));
-
- if ( keyRelation < 0 )
- upper = mid - 1;
-diff --git a/aapl/bubblesort.h b/aapl/bubblesort.h
-index bcc2fb6..f0f4ce5 100644
---- a/aapl/bubblesort.h
-+++ b/aapl/bubblesort.h
-@@ -72,7 +72,7 @@ template <class T, class Compare> void BubbleSort<T,Compare>::
- changed = false;
- for ( long i = 0; i < len-pass; i++ ) {
- /* Do we swap pos with the next one? */
-- if ( compare( data[i], data[i+1] ) > 0 ) {
-+ if ( this->compare( data[i], data[i+1] ) > 0 ) {
- char tmp[sizeof(T)];
-
- /* Swap the two items. */
-diff --git a/aapl/mergesort.h b/aapl/mergesort.h
-index 68b8426..8cefa73 100644
---- a/aapl/mergesort.h
-+++ b/aapl/mergesort.h
-@@ -110,7 +110,7 @@ template< class T, class Compare> void MergeSort<T,Compare>::
- }
- else {
- /* Both upper and lower left. */
-- if ( compare(*lower, *upper) <= 0 )
-+ if ( this->compare(*lower, *upper) <= 0 )
- memcpy( dest++, lower++, sizeof(T) );
- else
- memcpy( dest++, upper++, sizeof(T) );
---
-1.7.8.6
-
diff --git a/dev-util/ragel/files/ragel-6.7-cross-compile.patch b/dev-util/ragel/files/ragel-6.7-cross-compile.patch
deleted file mode 100644
index e953a1aeeeef..000000000000
--- a/dev-util/ragel/files/ragel-6.7-cross-compile.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-https://bugs.gentoo.org/473970
-
-already sent upstream
-
-patch by Jungshik Shin
-
---- ragel-6.7/configure.in
-+++ ragel-6.7/configure.in
-@@ -27,9 +27,9 @@
-
- dnl Choose defaults for the build_parsers and build_manual vars. If the dist
- dnl file is present in the root then default to no, otherwise go for it.
--AC_CHECK_FILES( $srcdir/DIST,
-- [ . $srcdir/DIST; ],
-- [ build_parsers=yes; build_manual=yes; ] )
-+
-+AS_IF([test -r $srcdir/DIST], [. $srcdir/DIST], [build_parsers=yes;
-+ build_manual=yes])
-
- dnl
- dnl Enable arg to explicitly control the building of the manual
diff --git a/dev-util/ragel/files/ragel-6.9-gcc6.patch b/dev-util/ragel/files/ragel-6.9-gcc6.patch
deleted file mode 100644
index fb10d9fd2b79..000000000000
--- a/dev-util/ragel/files/ragel-6.9-gcc6.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Bug: https://bugs.gentoo.org/582606
-
---- a/ragel/common.cpp
-+++ b/ragel/common.cpp
-@@ -34,7 +34,7 @@
- { "int", 0, "int", true, true, false, INT_MIN, INT_MAX, sizeof(int) },
- { "unsigned", "int", "uint", false, true, false, 0, UINT_MAX, sizeof(unsigned int) },
- { "long", 0, "long", true, true, false, LONG_MIN, LONG_MAX, sizeof(long) },
-- { "unsigned", "long", "ulong", false, true, false, 0, ULONG_MAX, sizeof(unsigned long) }
-+ { "unsigned", "long", "ulong", false, true, false, 0, (long long) ULONG_MAX, sizeof(unsigned long) }
- };
-
- #define S8BIT_MIN -128
-@@ -87,7 +87,7 @@
- { "int32", 0, "int32", true, true, false, S32BIT_MIN, S32BIT_MAX, 4 },
- { "uint32", 0, "uint32", false, true, false, U32BIT_MIN, U32BIT_MAX, 4 },
- { "int64", 0, "int64", true, true, false, S64BIT_MIN, S64BIT_MAX, 8 },
-- { "uint64", 0, "uint64", false, true, false, U64BIT_MIN, U64BIT_MAX, 8 },
-+ { "uint64", 0, "uint64", false, true, false, U64BIT_MIN, (long long) U64BIT_MAX, 8 },
- { "rune", 0, "int32", true, true, true, S32BIT_MIN, S32BIT_MAX, 4 }
- };
-
-@@ -116,7 +116,7 @@
- { "int", 0, "int", true, true, false, INT_MIN, INT_MAX, 4 },
- { "uint", 0, "uint", false, true, false, 0, UINT_MAX, 4 },
- { "long", 0, "long", true, true, false, LONG_MIN, LONG_MAX, 8 },
-- { "ulong", 0, "ulong", false, true, false, 0, ULONG_MAX, 8 }
-+ { "ulong", 0, "ulong", false, true, false, 0, (long long) ULONG_MAX, 8 }
- };
-
- HostType hostTypesOCaml[] =
---- a/ragel/rbxgoto.cpp
-+++ b/ragel/rbxgoto.cpp
-@@ -658,7 +658,7 @@
- out <<
- " begin\n"
- " " << P() << " += 1\n"
-- " " << rbxGoto(ret, "_out") << "\n"
-+ " " << static_cast<bool>(rbxGoto(ret, "_out")) << "\n"
- " end\n";
- }
-
diff --git a/dev-util/ragel/files/ragel-7.0.0.10-use-pkginclude.patch b/dev-util/ragel/files/ragel-7.0.0.10-use-pkginclude.patch
deleted file mode 100644
index 6609af5a99a2..000000000000
--- a/dev-util/ragel/files/ragel-7.0.0.10-use-pkginclude.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 927f380272442ae803fdccfc001b55877f25e7dc Mon Sep 17 00:00:00 2001
-From: Adrian Thurston <thurston@colm.net>
-Date: Sat, 10 Dec 2016 15:41:30 -0500
-Subject: [PATCH] use pkginclude for the headers
-
----
- aapl/Makefile.am | 2 +-
- src/Makefile.am | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/aapl/Makefile.am b/aapl/Makefile.am
-index fd9f9cb0..80b972f1 100644
---- a/aapl/Makefile.am
-+++ b/aapl/Makefile.am
-@@ -1,4 +1,4 @@
--include_HEADERS = \
-+pkginclude_HEADERS = \
- avlbasic.h avlimel.h avlmap.h bstcommon.h compare.h insertsort.h \
- sbstset.h avlcommon.h avlimelkey.h avlmel.h bstmap.h dlcommon.h \
- mergesort.h sbsttable.h avlibasic.h avliset.h avlmelkey.h bstset.h \
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 24a19a4b..60554a99 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -16,11 +16,11 @@ bin_PROGRAMS = ragel
-
- endif
-
--include_HEADERS = \
-+pkginclude_HEADERS = \
- action.h fsmgraph.h ragel.h common.h \
- gendata.h redfsm.h dot.h
-
--nodist_include_HEADERS = config.h
-+nodist_pkginclude_HEADERS = config.h
-
- ragel_CPPFLAGS = -I$(top_srcdir)/aapl -DBINDIR='"@bindir@"'
-
---
-2.15.1
-