summaryrefslogtreecommitdiff
path: root/dev-util/quilt/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/quilt/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/quilt/files')
-rw-r--r--dev-util/quilt/files/quilt-0.50-no-graphviz.patch47
-rw-r--r--dev-util/quilt/files/quilt-0.63-bash-completion.patch17
-rw-r--r--dev-util/quilt/files/quilt-0.63-no-graphviz.patch43
-rw-r--r--dev-util/quilt/files/quilt-0.65-no-graphviz.patch43
4 files changed, 150 insertions, 0 deletions
diff --git a/dev-util/quilt/files/quilt-0.50-no-graphviz.patch b/dev-util/quilt/files/quilt-0.50-no-graphviz.patch
new file mode 100644
index 000000000000..04e0d7d3a9a1
--- /dev/null
+++ b/dev-util/quilt/files/quilt-0.50-no-graphviz.patch
@@ -0,0 +1,47 @@
+Index: b/Makefile.in
+===================================================================
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -82,8 +82,7 @@ QUILT := $(QUILT_IN)
+ SRC += $(QUILT_SRC:%=quilt/%)
+ DIRT += $(QUILT_IN:%=quilt/%)
+
+-SCRIPTS_IN := patchfns parse-patch inspect dependency-graph edmail \
+- remove-trailing-ws
++SCRIPTS_IN := patchfns parse-patch inspect edmail remove-trailing-ws
+
+ SCRIPTS_SRC := $(SCRIPTS_IN:%=%.in)
+ SCRIPTS := $(SCRIPTS_IN)
+Index: b/bash_completion
+===================================================================
+--- a/bash_completion
++++ b/bash_completion
+@@ -95,7 +95,7 @@ _quilt_completion()
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ # quilt sub commands
+- cmds='add annotate applied delete diff edit files fold fork graph \
++ cmds='add annotate applied delete diff edit files fold fork \
+ grep header import mail new next patches pop previous push refresh \
+ remove rename revert series setup snapshot top unapplied'
+
+@@ -189,19 +189,6 @@ _quilt_completion()
+ ;;
+ esac
+ ;;
+- graph)
+- case $prev in
+- -T)
+- COMPREPLY=( $( compgen -W "ps" -- $cur ) )
+- ;;
+- --edge-labels)
+- COMPREPLY=( $( compgen -W "files" -- $cur ) )
+- ;;
+- *)
+- COMPREPLY=( $( compgen -W "-T -h --all --reduce --lines --edge-labels $(quilt applied 2>/dev/null)" -- $cur ) )
+- ;;
+- esac
+- ;;
+ grep)
+ _longopt grep
+ COMPREPLY=( ${COMPREPLY[@]:-} $( compgen -W "-h" -- $cur ) )
diff --git a/dev-util/quilt/files/quilt-0.63-bash-completion.patch b/dev-util/quilt/files/quilt-0.63-bash-completion.patch
new file mode 100644
index 000000000000..c85caca5c9e1
--- /dev/null
+++ b/dev-util/quilt/files/quilt-0.63-bash-completion.patch
@@ -0,0 +1,17 @@
+--- bash_completion.orig 2014-10-21 18:15:29.549789267 -0400
++++ bash_completion 2014-10-21 18:15:38.489789221 -0400
+@@ -11,8 +11,6 @@
+ # completion to work then you must set QUILT_PC in your global environment
+ # (for example in ~/.profile) and not just in your quiltrc file.
+
+-if type quilt &> /dev/null ; then
+-
+ if ! type _expand &> /dev/null ; then
+ # This function expands tildes in pathnames
+ #
+@@ -310,5 +308,3 @@ _quilt_completion()
+ && _quilt_complete_opt="-o filenames"
+ complete -F _quilt_completion $_quilt_complete_opt quilt
+ unset -v _quilt_complete_opt
+-
+-fi
diff --git a/dev-util/quilt/files/quilt-0.63-no-graphviz.patch b/dev-util/quilt/files/quilt-0.63-no-graphviz.patch
new file mode 100644
index 000000000000..80458120f4f1
--- /dev/null
+++ b/dev-util/quilt/files/quilt-0.63-no-graphviz.patch
@@ -0,0 +1,43 @@
+--- Makefile.in.orig 2014-10-21 17:08:25.639810130 -0400
++++ Makefile.in 2014-10-21 17:09:03.269809935 -0400
+@@ -79,8 +79,7 @@ QUILT := $(QUILT_IN)
+ SRC += $(QUILT_SRC:%=quilt/%)
+ DIRT += $(QUILT_IN:%=quilt/%)
+
+-SCRIPTS_IN := patchfns inspect dependency-graph edmail \
+- remove-trailing-ws backup-files
++SCRIPTS_IN := patchfns inspect edmail remove-trailing-ws backup-files
+
+ SCRIPTS_SRC := $(SCRIPTS_IN:%=%.in)
+ SCRIPTS := $(SCRIPTS_IN)
+--- bash_completion.orig 2014-10-21 17:09:08.789809906 -0400
++++ bash_completion 2014-10-21 17:09:53.189809676 -0400
+@@ -100,7 +100,7 @@ _quilt_completion()
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ # quilt sub commands
+- cmds='add annotate applied delete diff edit files fold fork graph \
++ cmds='add annotate applied delete diff edit files fold fork \
+ grep header import mail new next patches pop previous push refresh \
+ remove rename revert series setup snapshot top unapplied'
+
+@@ -194,19 +194,6 @@ _quilt_completion()
+ ;;
+ esac
+ ;;
+- graph)
+- case $prev in
+- -T)
+- COMPREPLY=( $( compgen -W "ps" -- $cur ) )
+- ;;
+- --edge-labels)
+- COMPREPLY=( $( compgen -W "files" -- $cur ) )
+- ;;
+- *)
+- COMPREPLY=( $( compgen -W "-T -h --all --reduce --lines --edge-labels $(quilt --quiltrc - applied 2>/dev/null)" -- $cur ) )
+- ;;
+- esac
+- ;;
+ grep)
+ _longopt grep
+ COMPREPLY=( ${COMPREPLY[@]:-} $( compgen -W "-h" -- $cur ) )
diff --git a/dev-util/quilt/files/quilt-0.65-no-graphviz.patch b/dev-util/quilt/files/quilt-0.65-no-graphviz.patch
new file mode 100644
index 000000000000..ea06a9eebefb
--- /dev/null
+++ b/dev-util/quilt/files/quilt-0.65-no-graphviz.patch
@@ -0,0 +1,43 @@
+--- Makefile.in.orig 2017-04-12 09:27:40.853018901 -0400
++++ Makefile.in 2017-04-12 09:36:16.584315529 -0400
+@@ -78,8 +78,7 @@ QUILT := $(QUILT_IN)
+ SRC += $(QUILT_SRC:%=quilt/%)
+ DIRT += $(QUILT_IN:%=quilt/%)
+
+-SCRIPTS_IN := patchfns inspect-wrapper dependency-graph edmail \
+- remove-trailing-ws backup-files
++SCRIPTS_IN := patchfns inspect-wrapper edmail remove-trailing-ws backup-files
+
+ SCRIPTS_SRC := $(SCRIPTS_IN:%=%.in)
+ SCRIPTS := $(SCRIPTS_IN)
+--- bash_completion.orig 2017-04-12 09:27:57.643126246 -0400
++++ bash_completion 2017-04-12 09:30:27.673938451 -0400
+@@ -28,7 +28,7 @@ _quilt_completion()
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ # quilt sub commands
+- cmds='add annotate applied delete diff edit files fold fork graph \
++ cmds='add annotate applied delete diff edit files fold fork \
+ grep header import mail new next patches pop previous push refresh \
+ remove rename revert series setup snapshot top unapplied upgrade'
+
+@@ -122,19 +122,6 @@ _quilt_completion()
+ ;;
+ esac
+ ;;
+- graph)
+- case $prev in
+- -T)
+- COMPREPLY=( $( compgen -W "ps" -- $cur ) )
+- ;;
+- --edge-labels)
+- COMPREPLY=( $( compgen -W "files" -- $cur ) )
+- ;;
+- *)
+- COMPREPLY=( $( compgen -W "-T -h --all --reduce --lines --edge-labels $(quilt --quiltrc - applied 2>/dev/null)" -- $cur ) )
+- ;;
+- esac
+- ;;
+ grep)
+ type _longopt &> /dev/null && _longopt grep
+ COMPREPLY=( "${COMPREPLY[@]}" $( compgen -W "-h" -- $cur ) )