summaryrefslogtreecommitdiff
path: root/dev-util/quilt/files/quilt-0.50-no-graphviz.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/quilt/files/quilt-0.50-no-graphviz.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/quilt/files/quilt-0.50-no-graphviz.patch')
-rw-r--r--dev-util/quilt/files/quilt-0.50-no-graphviz.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/quilt/files/quilt-0.50-no-graphviz.patch b/dev-util/quilt/files/quilt-0.50-no-graphviz.patch
new file mode 100644
index 000000000000..04e0d7d3a9a1
--- /dev/null
+++ b/dev-util/quilt/files/quilt-0.50-no-graphviz.patch
@@ -0,0 +1,47 @@
+Index: b/Makefile.in
+===================================================================
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -82,8 +82,7 @@ QUILT := $(QUILT_IN)
+ SRC += $(QUILT_SRC:%=quilt/%)
+ DIRT += $(QUILT_IN:%=quilt/%)
+
+-SCRIPTS_IN := patchfns parse-patch inspect dependency-graph edmail \
+- remove-trailing-ws
++SCRIPTS_IN := patchfns parse-patch inspect edmail remove-trailing-ws
+
+ SCRIPTS_SRC := $(SCRIPTS_IN:%=%.in)
+ SCRIPTS := $(SCRIPTS_IN)
+Index: b/bash_completion
+===================================================================
+--- a/bash_completion
++++ b/bash_completion
+@@ -95,7 +95,7 @@ _quilt_completion()
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ # quilt sub commands
+- cmds='add annotate applied delete diff edit files fold fork graph \
++ cmds='add annotate applied delete diff edit files fold fork \
+ grep header import mail new next patches pop previous push refresh \
+ remove rename revert series setup snapshot top unapplied'
+
+@@ -189,19 +189,6 @@ _quilt_completion()
+ ;;
+ esac
+ ;;
+- graph)
+- case $prev in
+- -T)
+- COMPREPLY=( $( compgen -W "ps" -- $cur ) )
+- ;;
+- --edge-labels)
+- COMPREPLY=( $( compgen -W "files" -- $cur ) )
+- ;;
+- *)
+- COMPREPLY=( $( compgen -W "-T -h --all --reduce --lines --edge-labels $(quilt applied 2>/dev/null)" -- $cur ) )
+- ;;
+- esac
+- ;;
+ grep)
+ _longopt grep
+ COMPREPLY=( ${COMPREPLY[@]:-} $( compgen -W "-h" -- $cur ) )