summaryrefslogtreecommitdiff
path: root/dev-util/qmtest/qmtest-2.4.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/qmtest/qmtest-2.4.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/qmtest/qmtest-2.4.1-r1.ebuild')
-rw-r--r--dev-util/qmtest/qmtest-2.4.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/qmtest/qmtest-2.4.1-r1.ebuild b/dev-util/qmtest/qmtest-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..93ad4a8feb92
--- /dev/null
+++ b/dev-util/qmtest/qmtest-2.4.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="CodeSourcery's test harness system"
+HOMEPAGE="http://www.codesourcery.com/qmtest/"
+SRC_URI="http://www.codesourcery.com/public/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ distutils-r1_src_install
+ find "${ED}" -name config.py -print0 | xargs -0 sed -i "s:${ED}:${EPREFIX}/usr:"
+ rm -r "${ED}"usr/share/doc/${PN}/{COPYING,LICENSE.OPL} || die
+ mv "${ED}"usr/share/doc/${PN}/* "${ED}"usr/share/doc/${PF} || die
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+}