summaryrefslogtreecommitdiff
path: root/dev-util/qdevicemonitor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/qdevicemonitor
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/qdevicemonitor')
-rw-r--r--dev-util/qdevicemonitor/Manifest4
-rw-r--r--dev-util/qdevicemonitor/metadata.xml16
-rw-r--r--dev-util/qdevicemonitor/qdevicemonitor-1.0.1.ebuild46
-rw-r--r--dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild46
4 files changed, 112 insertions, 0 deletions
diff --git a/dev-util/qdevicemonitor/Manifest b/dev-util/qdevicemonitor/Manifest
new file mode 100644
index 000000000000..77d9d35abd54
--- /dev/null
+++ b/dev-util/qdevicemonitor/Manifest
@@ -0,0 +1,4 @@
+DIST qdevicemonitor-1.0.1.tar.gz 955052 SHA256 33bd193dd6ad492973ec1fd0c6076bf3c3e9b90deb04f9c39c3f15095d98712b SHA512 c393d8e33aa6234c2b62af8c25e5fc2e6ccacf9734b77500a512fbd584ecde723b9d5717dbe268d65565d3d30801d297236b3546263ba2689ba246d2b13b8f55 WHIRLPOOL 0b1a1f24ea21897adcf24e5a3ff3dcb42244052c6cf28d6898791c50c250376f98b82496d680c5693bbc680eff8f826134de666e5226c1226ed2e8927d1b13ee
+EBUILD qdevicemonitor-1.0.1.ebuild 919 SHA256 c0cf0f41994ce0a733a49607029aeb1621d4a779fabc87031a80f009efb2cfed SHA512 6f82903b9aefcef70c88766a5907e1dd14ec1bbdd9163eec724b8c6cb6c23e2ab0375796f443c73fd1944d1dbb0782c8c2a32a426a07becaefe06e38e0423f70 WHIRLPOOL c4e4d45044373a8f0ef3ab7e39e0317482ed921558307d93cc98ffb37b3bf5168338896875566d8b45e858d00c3bc8ec3296914f982e213f7d4fa4c0561041d0
+EBUILD qdevicemonitor-9999.ebuild 919 SHA256 c0cf0f41994ce0a733a49607029aeb1621d4a779fabc87031a80f009efb2cfed SHA512 6f82903b9aefcef70c88766a5907e1dd14ec1bbdd9163eec724b8c6cb6c23e2ab0375796f443c73fd1944d1dbb0782c8c2a32a426a07becaefe06e38e0423f70 WHIRLPOOL c4e4d45044373a8f0ef3ab7e39e0317482ed921558307d93cc98ffb37b3bf5168338896875566d8b45e858d00c3bc8ec3296914f982e213f7d4fa4c0561041d0
+MISC metadata.xml 508 SHA256 d432104e84282cbe0adc5e5582f0a9a54089baeb4b58e78e9952d75548ef1531 SHA512 90fc779f3aaa323f0842ba08241a0556e72ee6581ee47a944063712f9e4f17a840686a0aa5f14a1151f6df3f7b0580b9e42913a91c5eaf11fcce9086922e3997 WHIRLPOOL 822536e007b34f84af141e0c7fab8d84ecfdbb15946ece2d9c2b6ff980445acd65214619d8629198f542db4cf8cc032398249047df527847071cf1c7207f5f13
diff --git a/dev-util/qdevicemonitor/metadata.xml b/dev-util/qdevicemonitor/metadata.xml
new file mode 100644
index 000000000000..5351b1543c26
--- /dev/null
+++ b/dev-util/qdevicemonitor/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alopatindev@gmail.com</email>
+ <name>Alexander Lopatin</name>
+ <description>Proxy maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">alopatindev/qdevicemonitor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/qdevicemonitor/qdevicemonitor-1.0.1.ebuild b/dev-util/qdevicemonitor/qdevicemonitor-1.0.1.ebuild
new file mode 100644
index 000000000000..c055bb2fca97
--- /dev/null
+++ b/dev-util/qdevicemonitor/qdevicemonitor-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils qmake-utils
+
+DESCRIPTION="Crossplatform log viewer for Android, iOS and text files"
+HOMEPAGE="https://github.com/alopatindev/qdevicemonitor"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alopatindev/${PN}"
+else
+ SRC_URI="https://github.com/alopatindev/qdevicemonitor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-util/android-tools
+ app-pda/usbmuxd"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ cd "${PN}" || die
+ export VERSION_WITH_BUILD_NUMBER="${PV}"
+ eqmake5
+}
+
+src_compile() {
+ cd "${PN}" || die
+ emake
+}
+
+src_install() {
+ dobin "${PN}/${PN}"
+ dodoc README.md
+ newicon -s scalable "icons/app_icon.svg" "${PN}.svg"
+ domenu "icons/${PN}.desktop"
+}
diff --git a/dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild b/dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild
new file mode 100644
index 000000000000..c055bb2fca97
--- /dev/null
+++ b/dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils qmake-utils
+
+DESCRIPTION="Crossplatform log viewer for Android, iOS and text files"
+HOMEPAGE="https://github.com/alopatindev/qdevicemonitor"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alopatindev/${PN}"
+else
+ SRC_URI="https://github.com/alopatindev/qdevicemonitor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-util/android-tools
+ app-pda/usbmuxd"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ cd "${PN}" || die
+ export VERSION_WITH_BUILD_NUMBER="${PV}"
+ eqmake5
+}
+
+src_compile() {
+ cd "${PN}" || die
+ emake
+}
+
+src_install() {
+ dobin "${PN}/${PN}"
+ dodoc README.md
+ newicon -s scalable "icons/app_icon.svg" "${PN}.svg"
+ domenu "icons/${PN}.desktop"
+}