summaryrefslogtreecommitdiff
path: root/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r1.ebuild')
-rw-r--r--dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r1.ebuild b/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..1b9b31c6c9dd
--- /dev/null
+++ b/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit desktop qmake-utils
+
+DESCRIPTION="Crossplatform log viewer for Android, iOS and text files"
+HOMEPAGE="https://github.com/alopatindev/qdevicemonitor"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alopatindev/${PN}"
+else
+ SRC_URI="https://github.com/alopatindev/qdevicemonitor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-util/android-tools
+ app-pda/usbmuxd"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-qt-5.11.patch
+ "${FILESDIR}"/${P}-crash-after-fresh-install.patch
+)
+
+src_configure() {
+ cd "${PN}" || die
+ export VERSION_WITH_BUILD_NUMBER="${PV}"
+ eqmake5
+}
+
+src_compile() {
+ cd "${PN}" || die
+ emake
+}
+
+src_install() {
+ dobin "${PN}/${PN}"
+ dodoc README.md
+ newicon -s scalable "icons/app_icon.svg" "${PN}.svg"
+ domenu "icons/${PN}.desktop"
+}