summaryrefslogtreecommitdiff
path: root/dev-util/pycharm-community
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-util/pycharm-community
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-util/pycharm-community')
-rw-r--r--dev-util/pycharm-community/Manifest2
-rw-r--r--dev-util/pycharm-community/pycharm-community-2018.2.4.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index c5957dc95da2..16b7167725b5 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -1,4 +1,6 @@
AUX README.gentoo 169 BLAKE2B fc7191056cb5de1fedf9a7e9516029e8ee50f7ab3749e05c73156f63892b1e126ac068d5b2f271d1b71a77486205848cce72452d671692418b6e09e8e25da60e SHA512 a0254552b98b6ec8dadd91ed7df35bf990d08025d8352366f58ecabe94cdde2df64d8665447d0a2ffc1edacdeb05124c2a82722d5ad70b614d90bb0ae38544d2
DIST pycharm-community-2018.2.1.tar.gz 260758803 BLAKE2B 735d3e7483b46a9be8bf0a8fa88a51352b1048718aab00b63c133a408666e151947ded527b4ed754ce15aff17a3da9396e10b9194e61286f0ed0534d51f0eabe SHA512 bcae7f579664aa9b071eef6fedc68dad8c9e36078c258cee6877ada1247f9051c4d542657ef2b01dce087e273623b84d86d786ddf1e922d7c6599725f50428bd
+DIST pycharm-community-2018.2.4.tar.gz 260812419 BLAKE2B 2274d8af513535e4c5b3b69619c944f503dd9f2248a43cf3352221b34c40604f409038d85366321e858037e3c9c63dc838c046917c3102a2d536e4aef05c1636 SHA512 aca812b3355552c6a65865385e82c96fbca06f9caa39fd21723710922865f7aeb38de33eb041efb1e3553e161c34de6d8b8ed724d7c91ba16f3a818711ca9468
EBUILD pycharm-community-2018.2.1.ebuild 1063 BLAKE2B 72a3afd5b6cb81cc3dfc0bdf0fd7e1c052038ae3faf5e7ffed57884040b82cd238172291fc3ea050dab92348a29ebdbbdad75de6b2e4b512eee019b5bbffd093 SHA512 4bdb36f6a983323d44defe031f738953567df7a01f775e02b943336579727808c0ab832e49aa367daa6d26b28eb30edf5a4b110addd172b4e9d898bcc93713f1
+EBUILD pycharm-community-2018.2.4.ebuild 1065 BLAKE2B 8cfea152ff94162e0ae06ae07fd4c2c9eccf8db137171fce459e79fceeebab72e42d2d6f7bf403fc1b5a2312208f67e72de550950f8a1a45430d4e10ad000b74 SHA512 ef3e04fef80f172a3173c53d1d82a760d0ce1aa14631b01717eb900492179727d8a7c4c94b1814aaf382dda908a11f99e367832c72859a731fa63671243296ca
MISC metadata.xml 237 BLAKE2B f22c3926ba75c18fce7667217807f3710a315b12b1341622c949e7bc0056cd1cb403ea6c66d838675f3cb5dcd53d2fc4ec71425ec3f96aaffb94b70b73e99320 SHA512 ae2360aa6b1b00c67e0acea4935c02b64585b9a15e126fec9d5d99637021c542c0a495e5116205f3da287def46fa5b19cb1a7f3042c12c5f7a78d66d92fcb03f
diff --git a/dev-util/pycharm-community/pycharm-community-2018.2.4.ebuild b/dev-util/pycharm-community/pycharm-community-2018.2.4.ebuild
new file mode 100644
index 000000000000..c37c85ebc8eb
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2018.2.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8
+ dev-python/pip"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+ opt/${PN}/bin/fsnotifier64
+ opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_prepare() {
+ default
+
+ rm -rf jre || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}