summaryrefslogtreecommitdiff
path: root/dev-util/pscan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-util/pscan
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-util/pscan')
-rw-r--r--dev-util/pscan/Manifest5
-rw-r--r--dev-util/pscan/files/pscan-20000721-fix-build-system.patch20
-rw-r--r--dev-util/pscan/pscan-20000721-r1.ebuild21
3 files changed, 32 insertions, 14 deletions
diff --git a/dev-util/pscan/Manifest b/dev-util/pscan/Manifest
index 7f379a832363..b419922f5eed 100644
--- a/dev-util/pscan/Manifest
+++ b/dev-util/pscan/Manifest
@@ -1,3 +1,4 @@
-DIST pscan.tar.gz 14555 BLAKE2B 8e1a8ea91bc2a1b323dc607f703565579e596a3001151609e46a09160766b3b913610a15b64859dc88031a3acf2e3c147dcbd7b033517d3786976ab3cb1bc9f4 SHA512 83196cc9c450217fc2287d38fd1a0b9d1d9951b8f6328b6b9f7f50b680f653b099af04d4c448f3cb2b2a96871eec8772557851e887faa2f41dc259f01c031e78
-EBUILD pscan-20000721-r1.ebuild 843 BLAKE2B 3fd9ff6066f1e57413c5c2aa1ec6e69102653d88e6713267b3e70b533bcd68ddde2b5dc84ffc5f169baca72379c116b2ab321b36c47dcf25232f1135f8bb4d3f SHA512 bd81029aeaae61446dbf2f4e8ac3b94b689a51ea30a9b0ef99c9a5435bc6aa90b2a655df5f43db91ab912e9854629fecdaf6bb1499f57e3857af376c4e05d8d7
+AUX pscan-20000721-fix-build-system.patch 380 BLAKE2B 93c29ae8c17a798bd7b0a28c43dfed21410f336fa17c7ba58c2c9b5588831ad6ca6e056d2cf9d6375bc2ba1e043665525aa58e903545691f9d6bd21616d11b5d SHA512 9c0e2b237553ae396398c0e0727b5eed7879ea112d940289c60be4e3f289dbcddeedbbfb4c9563e558dbc96d0f7420e672b9d70cc488be86b00ef42b5abbf76c
+DIST pscan-20000721.tar.gz 14555 BLAKE2B 8e1a8ea91bc2a1b323dc607f703565579e596a3001151609e46a09160766b3b913610a15b64859dc88031a3acf2e3c147dcbd7b033517d3786976ab3cb1bc9f4 SHA512 83196cc9c450217fc2287d38fd1a0b9d1d9951b8f6328b6b9f7f50b680f653b099af04d4c448f3cb2b2a96871eec8772557851e887faa2f41dc259f01c031e78
+EBUILD pscan-20000721-r1.ebuild 743 BLAKE2B f7020c464af54a911d5d51d240371895799cf89d40d210b388d9c0fe568616d359187432ff4612df1ff4f0fe9addb7c68288b3346d8b7f783f9544bafbae73dd SHA512 0aaf95f7a7e037aba1d0fc24fb8045ee9cd08fbf3f27299c0ce995729519f1f788bb3d3addf98f82eaec101f79a0a82c6ee6352f999e68b8ac5b30a1e35d7b4b
MISC metadata.xml 216 BLAKE2B 20531789dc11e43feee7ec315a0c1c7249fdf73764e29cb7d6db439826e9ff72f24a5cdb8eb7f1ab99bbb41fb6e4226874a1d1fa4185de52598602bb3b0479a3 SHA512 e881b59fe49746eb25ad66c258b41aba501e4eb563129093a3898ea970a20506e7898f7c355cfcf99605234962bf2c77c1309c258b9a2b84ee4302ccb71c9dbd
diff --git a/dev-util/pscan/files/pscan-20000721-fix-build-system.patch b/dev-util/pscan/files/pscan-20000721-fix-build-system.patch
new file mode 100644
index 000000000000..cd22fc2eb195
--- /dev/null
+++ b/dev-util/pscan/files/pscan-20000721-fix-build-system.patch
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -13,16 +13,10 @@
+ #CC=gcc -Wall -g
+ #LEX=flex
+
+-pscan: scanner.yy.o pscan.o
+- $(CC) scanner.yy.o pscan.o -o pscan
+-
+-scanner.yy.o: scanner.yy.c
+- $(CC) -c scanner.yy.c -o scanner.yy.o
++pscan: scanner.yy.o
+
+ scanner.yy.c: scanner.l
+ $(LEX) -t scanner.l > scanner.yy.c
+
+-pscan.o: pscan.c pscan.h
+-
+ clean:
+ rm -f *.o *~ pscan scanner.yy.c core
diff --git a/dev-util/pscan/pscan-20000721-r1.ebuild b/dev-util/pscan/pscan-20000721-r1.ebuild
index 11c078d3650b..e63242af2bde 100644
--- a/dev-util/pscan/pscan-20000721-r1.ebuild
+++ b/dev-util/pscan/pscan-20000721-r1.ebuild
@@ -1,34 +1,31 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit toolchain-funcs
DESCRIPTION="A limited problem scanner for C source files"
HOMEPAGE="http://www.striker.ottawa.on.ca/~aland/pscan/"
-# I wish upstream would version their files, even if it's only with a date
-SRC_URI="http://www.striker.ottawa.on.ca/~aland/pscan/pscan.tar.gz"
+SRC_URI="mirror://gentoo/pscan.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
-
# Does NOT contain a testsuite, but does contain a test.c that confuses src_test
RESTRICT="test"
-RDEPEND=""
-DEPEND="${RDEPEND}
- sys-devel/flex"
+BDEPEND="sys-devel/flex"
S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
-src_compile() {
- emake CC="$(tc-getCC) ${CFLAGS}" || die
+src_configure() {
+ tc-export CC
}
src_install() {
- newbin pscan printf-scan || die
- dodoc README find_formats.sh test.c wu-ftpd.pscan || die
+ newbin pscan printf-scan
+ dodoc README find_formats.sh test.c wu-ftpd.pscan
}