summaryrefslogtreecommitdiff
path: root/dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild')
-rw-r--r--dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild b/dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild
new file mode 100644
index 000000000000..1d4dbac95549
--- /dev/null
+++ b/dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Google Protocol Buffers serialization and RPC implementation for Ruby"
+HOMEPAGE="https://github.com/ruby-protobuf/protobuf"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ >=dev-ruby/activesupport-3.2:*
+ dev-ruby/middleware
+ dev-ruby/thor:*
+ dev-ruby/thread_safe
+"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile spec/spec_helper.rb || die
+
+ # Avoid unpackaged optional dependency
+ rm -f spec/lib/protobuf/rpc/connectors/{ping,zmq}_spec.rb spec/functional/zmq_server_spec.rb || die
+ rm -rf spec/lib/protobuf/rpc/servers/zmq || die
+ sed -i -e '/context .zmq/,/^ end/ s:^:#:' spec/lib/protobuf/cli_spec.rb || die
+}