summaryrefslogtreecommitdiff
path: root/dev-util/promu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-util/promu
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-util/promu')
-rw-r--r--dev-util/promu/Manifest2
-rw-r--r--dev-util/promu/promu-0.5.0.ebuild23
2 files changed, 11 insertions, 14 deletions
diff --git a/dev-util/promu/Manifest b/dev-util/promu/Manifest
index 531e6823cc79..d3618b9c4cdd 100644
--- a/dev-util/promu/Manifest
+++ b/dev-util/promu/Manifest
@@ -1,3 +1,3 @@
DIST promu-0.5.0.tar.gz 643970 BLAKE2B b61e8421b5e68f3cd0ec125faadf64c7491f54cfe03de9d6497cb627e5d548b58fafe735c76a5a86a55489aea56dffb6e02d52acd1ca977ea32ec974f34475ac SHA512 b895c0b5b5a33bd0c2372e8c1c698b8548b1b7086849161ffa99bf9718f4b7f3a57bcf218681d84e4cc5ef31ef39df7e6c59345a84441369ec3ec402999ac4de
-EBUILD promu-0.5.0.ebuild 867 BLAKE2B a8adf3266e7acb90a73b50d0a624161eb7bdbd25b176474b259a3cad1d1d6233fe014258a9b1740ad71cef2ec841d96320f2a0f556db1a39db0dbd0df5b953f3 SHA512 c09728becc3a7483c4d3fdaf95964626dea5f9c6dc93bcdaee7825e2123e2cfedad7c0ba2a58d2c2fcd20203ac56d4ba3f7daddcce8478505f27ba24fe0d26ea
+EBUILD promu-0.5.0.ebuild 675 BLAKE2B a9094322babbfc75b84eafff9026b7fe18f001a7dc8ea2849c08bb1135a3409534bce9efd0303acc214ccc0528633d6a382d6513747d70f7ae6d38f3c6f23896 SHA512 41f559803a6c7eaa7e2a4d7ecd9de42b900c4aafa9a5e0eb8c965c978f00261ecc4fd7814819dc4f04a5d03a19f42ccf9084fc467876508417d780a9eb598068
MISC metadata.xml 325 BLAKE2B a6e231de6312601f0f92df0d3422b3527b0869cb484ab20933c5fcfba14a3545b122c83e855df882da09b9016109473230f3c7e8b48e9597ffe755916a3890b4 SHA512 51a31843f4341e22ae270e21d32a672ef5ca9739aa8a2066f9d9da2d0451e3f27c890ee1809bae98a68a73a9b4ab9114c4eb056a1fcabda35ea092bf76e9156a
diff --git a/dev-util/promu/promu-0.5.0.ebuild b/dev-util/promu/promu-0.5.0.ebuild
index 7ede34ae7c3a..64f6ce821f01 100644
--- a/dev-util/promu/promu-0.5.0.ebuild
+++ b/dev-util/promu/promu-0.5.0.ebuild
@@ -1,35 +1,32 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit golang-build golang-vcs-snapshot
+EAPI=7
+inherit go-module
-EGO_PN="github.com/prometheus/promu"
EGIT_COMMIT="642a960b363a409efff7621dbf5b183d58670ec2"
-SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="amd64"
DESCRIPTION="Prometheus Utility Tool"
HOMEPAGE="https://github.com/prometheus/promu"
+SRC_URI="https://github.com/prometheus/promu/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
LICENSE="Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
+KEYWORDS="amd64"
IUSE=""
-RESTRICT="test"
-DEPEND=">=dev-lang/go-1.12"
+RESTRICT+=" test"
src_prepare() {
default
- sed -i -e "s/{{.Revision}}/${EGIT_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+ sed -i -e "s/{{.Revision}}/${EGIT_COMMIT}/" .promu.yml || die
}
src_compile() {
- pushd src/${EGO_PN} || die
- GO111MODULE=off GOCACHE="${T}/go-cache" GOPATH="${S}" go install -v github.com/prometheus/promu || die
- popd || die
+ go build -mod=vendor . || die "compile failed"
}
src_install() {
- dobin bin/*
- dodoc -r src/${EGO_PN}/{doc,{README,CONTRIBUTING}.md}
+ dobin ${PN}
+ dodoc -r {doc,{README,CONTRIBUTING}.md}
}