summaryrefslogtreecommitdiff
path: root/dev-util/promu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /dev-util/promu
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'dev-util/promu')
-rw-r--r--dev-util/promu/Manifest2
-rw-r--r--dev-util/promu/promu-0.1.0_p20180227.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/promu/Manifest b/dev-util/promu/Manifest
index dbeb9d2b3f1a..c25612b344b9 100644
--- a/dev-util/promu/Manifest
+++ b/dev-util/promu/Manifest
@@ -1,3 +1,5 @@
DIST promu-0.1.0.tar.gz 1065003 BLAKE2B f56dfda69dae632b1946182b1a92c059cac52867c677d415c2f321f95800d3902f8f0fbd4d4b670870f3dce34603b0c1a50df9311be70404f27e9f5afbaf4699 SHA512 18ad54b1ec9fe8975a0048b5c85609858cd500a2d3aa34e51e5c2c3d07a0df4337bac9648562e2007d5c8572e07c814c6bba7522b94836c258cde457df5815e2
+DIST promu-0.1.0_p20180227.tar.gz 1068386 BLAKE2B b850c1dfa51f86099bd7e32c131ef99a05d4f4caab441a945fddc9a2895e72b74ed3456f18ab69493fc2283902c570e78f99ea303f32998416fdfbf91c3d0cd8 SHA512 6fbe5fe92602437aee90a442028cd846d9d72179b32e601b6167420dab0a3aed22cd9d1c527320ca54a3cfce7b79167753ad9cbeb000762e845056c692212a74
EBUILD promu-0.1.0.ebuild 852 BLAKE2B 9233be82753b67b6396d85a6df6f49a7ea34857ee751c3b56dab70a47ce0eb7032d1abedf1d4c36ab83317050468b10598f09bfb2adefbbb43b2c15a5a4f474e SHA512 4bc962ebfd3c78d9e8190fa1c11262e8303d76c6ba95760c1dd1aa4a7d9cb8fbb2e4a8048a22737255e56927e0b09798237252b6cb4548afd97be4dbad1a3877
+EBUILD promu-0.1.0_p20180227.ebuild 898 BLAKE2B 8dff410ec5b0c1b8049f6b5b704076c7a3d190b5f545606f296f95e742d7cf2589d8a972ff4f9875d70c7f6fed7cbd98bafb3421f8f69f15ca297d6a158c340d SHA512 c5679affaaffa1d9bab60d3f0b965381161e94f24e88bfab6f6f19fe3b476ccdcbe7b60e6248235359b85f2f2ff0fa6992af1e13fc3d6112b4049128c6bd4d5c
MISC metadata.xml 326 BLAKE2B 84a14632c102d52e02ac2c9a8e7f8e2edfabb3401ab04d5fe94eab4c83ef053f27260aff0ad2b04769653665325afa6db028c8ee281835b925456b432d593eb1 SHA512 2870183c141e5d9ec65aba01e7ab02443f42d13d0f39c4ba51af7adacabdf360cb2308cb898c4bf4f0a8c3e20b35d511af2b978fafcb4de47177de77819f6853
diff --git a/dev-util/promu/promu-0.1.0_p20180227.ebuild b/dev-util/promu/promu-0.1.0_p20180227.ebuild
new file mode 100644
index 000000000000..94c084e7161a
--- /dev/null
+++ b/dev-util/promu/promu-0.1.0_p20180227.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/promu"
+EGIT_COMMIT="5a3cc08574c63bb853a21c570d719a0fb548dae0"
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus Utility Tool"
+HOMEPAGE="https://github.com/prometheus/promu"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ LDFLAGS="-X github.com/prometheus/vendor/github.com/prometheus/common/version.Version=$(cat src/${EGO_PN}/VERSION)
+ -X github.com/prometheus/vendor/github.com/prometheus/common/version.Revision=${EGIT_COMMIT:0:7}
+ -extldflags \"-static\""
+ GOPATH="${S}" go build -ldflags "${LDFLAGS}" -o bin/promu src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{doc,{README,CONTRIBUTING}.md}
+}