summaryrefslogtreecommitdiff
path: root/dev-util/pretrace/pretrace-0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /dev-util/pretrace/pretrace-0.4-r1.ebuild
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'dev-util/pretrace/pretrace-0.4-r1.ebuild')
-rw-r--r--dev-util/pretrace/pretrace-0.4-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/pretrace/pretrace-0.4-r1.ebuild b/dev-util/pretrace/pretrace-0.4-r1.ebuild
new file mode 100644
index 000000000000..998da63f1052
--- /dev/null
+++ b/dev-util/pretrace/pretrace-0.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit readme.gentoo-r1
+
+DESCRIPTION="start dynamically linked applications under debugging environment"
+HOMEPAGE="http://dev.inversepath.com/trac/pretrace"
+SRC_URI="http://dev.inversepath.com/pretrace/libpretrace-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/lib${P}"
+
+DOC_CONTENTS="Remember to execute ptgenmap after modifying pretrace.conf"
+
+PATCHES=(
+ "${FILESDIR}"/${P}--as-needed.diff
+ "${FILESDIR}"/${P}-build.patch #227923
+)
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man3 /usr/share/man/man8
+ emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" PREFIX="${D}/usr" install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}