summaryrefslogtreecommitdiff
path: root/dev-util/premake/premake-5.0.0_alpha16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
commite2db47eaae00ec33f8971db44b68645c5d3b9590 (patch)
tree3ec0cf16ddb5854017e134fabebe14bf8cb94a34 /dev-util/premake/premake-5.0.0_alpha16.ebuild
parent616579b5d773c50af31ee56f00105d96ce641ca2 (diff)
gentoo resync : 17.08.2021
Diffstat (limited to 'dev-util/premake/premake-5.0.0_alpha16.ebuild')
-rw-r--r--dev-util/premake/premake-5.0.0_alpha16.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/premake/premake-5.0.0_alpha16.ebuild b/dev-util/premake/premake-5.0.0_alpha16.ebuild
new file mode 100644
index 000000000000..af3a8cbff0f0
--- /dev/null
+++ b/dev-util/premake/premake-5.0.0_alpha16.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="A makefile generation tool"
+HOMEPAGE="https://premake.github.io"
+SRC_URI="https://github.com/premake/premake-core/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-core-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="5"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.0_alpha16-respect-MAKEOPTS-jobs.patch
+)
+
+src_compile() {
+ # bug #773505
+ tc-export AR CC
+
+ emake -f Bootstrap.mak linux
+}
+
+src_test() {
+ bin/release/premake${SLOT} test || die
+}
+
+src_install() {
+ dobin bin/release/premake${SLOT}
+
+ einstalldocs
+}