summaryrefslogtreecommitdiff
path: root/dev-util/premake/premake-4.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-util/premake/premake-4.3-r2.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-util/premake/premake-4.3-r2.ebuild')
-rw-r--r--dev-util/premake/premake-4.3-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/premake/premake-4.3-r2.ebuild b/dev-util/premake/premake-4.3-r2.ebuild
new file mode 100644
index 000000000000..3b333e7719c4
--- /dev/null
+++ b/dev-util/premake/premake-4.3-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A makefile generation tool"
+HOMEPAGE="http://industriousone.com/premake"
+SRC_URI="mirror://sourceforge/premake/${P}-src.zip"
+
+LICENSE="BSD"
+SLOT="4"
+KEYWORDS="amd64 ppc x86"
+
+BDEPEND="app-arch/unzip"
+
+PATCHES=(
+ "${FILESDIR}"/archless.patch
+)
+
+src_compile() {
+ emake -C build/gmake.unix/
+}
+
+src_install() {
+ dobin bin/release/premake4
+}