summaryrefslogtreecommitdiff
path: root/dev-util/ply/ply-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
commit896d6a8a88861c42b5d531a2f147c8a29a149bd8 (patch)
tree081fe10813721a96088dca6b54bc35bcac18afc6 /dev-util/ply/ply-2.3.0.ebuild
parent3059f20995d5ac642b7b4a38d538fdf1cc45d90d (diff)
gentoo auto-resync : 01:12:2022 - 20:53:45
Diffstat (limited to 'dev-util/ply/ply-2.3.0.ebuild')
-rw-r--r--dev-util/ply/ply-2.3.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/ply/ply-2.3.0.ebuild b/dev-util/ply/ply-2.3.0.ebuild
new file mode 100644
index 000000000000..f5bbba6567e2
--- /dev/null
+++ b/dev-util/ply/ply-2.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info
+
+DESCRIPTION="Dynamic instrumentation of the Linux kernel with BPF and kprobes"
+HOMEPAGE="https://github.com/iovisor/ply"
+SRC_URI="https://github.com/iovisor/ply/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/iovisor/ply/commit/1bc183af8703023e377f92716ecd3f339ffffd11.patch -> ${P}-arm-build-fix.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv"
+IUSE="static-libs"
+# Bug 733248 file collisions with sys-boot/plymouth:
+# /usr/lib64/libply.la
+# /usr/lib64/libply.so
+RDEPEND="!sys-boot/plymouth"
+DEPEND="elibc_musl? ( sys-libs/queue-standalone )"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~NET_CLS_BPF ~NET_ACT_BPF
+ ~BPF_JIT ~HAVE_EBPF_JIT ~BPF_EVENTS"
+
+ check_extra_config
+}
+
+src_prepare() {
+ sed -i "/^AC_INIT/c\AC_INIT(${PN}, ${PV}," configure.ac || die
+
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ rm -f "${ED}/usr/share/doc/${P}/COPYING"
+
+ if ! use static-libs; then
+ find "${D}" -type f -name '*.a' -delete || die
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}