summaryrefslogtreecommitdiff
path: root/dev-util/pkgconf/pkgconf-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-util/pkgconf/pkgconf-9999.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-util/pkgconf/pkgconf-9999.ebuild')
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index 780b57975a03..5f58337eda71 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -1,20 +1,21 @@
# Copyright 2012-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit multilib-minimal
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ #EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ EGIT_REPO_URI="https://git.dereferenced.org/${PN}/${PN}.git"
inherit autotools git-r3
else
SRC_URI="http://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
fi
-inherit multilib-minimal
-
DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
-HOMEPAGE="https://github.com/pkgconf/pkgconf"
+HOMEPAGE="https://git.dereferenced.org/pkgconf/pkgconf/"
LICENSE="ISC"
SLOT="0/3"
@@ -23,7 +24,7 @@ IUSE="+pkg-config test"
# tests require 'kyua'
RESTRICT="!test? ( test )"
-DEPEND="
+BDEPEND="
test? (
dev-libs/atf
dev-util/kyua
@@ -53,7 +54,8 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE=${S} econf
+ local ECONF_SOURCE="${S}"
+ econf
}
multilib_src_test() {
@@ -68,11 +70,14 @@ multilib_src_install() {
dosym pkgconf /usr/bin/pkg-config
dosym pkgconf.1 /usr/share/man/man1/pkg-config.1
else
- rm "${ED%/}"/usr/share/aclocal/pkg.m4 || die
+ rm "${ED}"/usr/share/aclocal/pkg.m4 || die
+ rmdir "${ED}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/man/man7/pkg.m4.7 || die
+ rmdir "${ED}"/usr/share/man/man7 || die
fi
}
multilib_src_install_all() {
einstalldocs
- find "${ED}" -name '*.la' -delete || die
+ find "${ED}" -type f -name '*.la' -delete || die
}