summaryrefslogtreecommitdiff
path: root/dev-util/pkgconf/pkgconf-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-07 08:11:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-07 08:11:30 +0100
commit79b62a1562ef813f413bc8facf13c063e5196c02 (patch)
treed64e8e8d4af338d87e4e19b06c647037ce6c9b77 /dev-util/pkgconf/pkgconf-9999.ebuild
parent21005a6009e62933ab3199ef84aef68f82b2b8d7 (diff)
gentoo auto-resync : 07:08:2022 - 08:11:30
Diffstat (limited to 'dev-util/pkgconf/pkgconf-9999.ebuild')
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild28
1 files changed, 11 insertions, 17 deletions
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index ecbccf339c73..a889721e17d0 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -1,26 +1,25 @@
# Copyright 2012-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit multilib multilib-minimal
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://gitea.treehouse.systems/ariadne/pkgconf.git"
else
SRC_URI="https://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~ppc-macos ~x64-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
HOMEPAGE="https://gitea.treehouse.systems/ariadne/pkgconf"
LICENSE="ISC"
-SLOT="0/3"
+SLOT="0/4"
IUSE="test"
-# tests require 'kyua'
RESTRICT="!test? ( test )"
BDEPEND="
@@ -29,31 +28,25 @@ BDEPEND="
dev-util/kyua
)
"
-RDEPEND="
- !dev-util/pkgconfig
-"
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/pkgconf$(get_exeext)
-)
+RDEPEND="!dev-util/pkgconfig"
src_prepare() {
default
- [[ ${PV} == "9999" ]] && eautoreconf
+ [[ ${PV} == 9999 ]] && eautoreconf
+
MULTILIB_CHOST_TOOLS+=(
/usr/bin/pkg-config$(get_exeext)
)
}
multilib_src_configure() {
- local ECONF_SOURCE="${S}"
- local args=(
- --disable-static
+ local myeconfargs=(
--with-system-includedir="${EPREFIX}/usr/include"
--with-system-libdir="${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)"
)
- econf "${args[@]}"
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_test() {
@@ -70,5 +63,6 @@ multilib_src_install() {
multilib_src_install_all() {
einstalldocs
+
find "${ED}" -type f -name '*.la' -delete || die
}