summaryrefslogtreecommitdiff
path: root/dev-util/pkgconf/pkgconf-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-util/pkgconf/pkgconf-9999.ebuild
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-util/pkgconf/pkgconf-9999.ebuild')
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild23
1 files changed, 7 insertions, 16 deletions
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index 463b0b7e2311..8ac703ecfd4c 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://git.sr.ht/~kaniini/pkgconf"
LICENSE="ISC"
SLOT="0/3"
-IUSE="+pkg-config test"
+IUSE="test"
# tests require 'kyua'
RESTRICT="!test? ( test )"
@@ -30,7 +30,7 @@ BDEPEND="
)
"
RDEPEND="
- pkg-config? ( !dev-util/pkgconfig )
+ !dev-util/pkgconfig
"
MULTILIB_CHOST_TOOLS=(
@@ -41,11 +41,9 @@ src_prepare() {
default
[[ ${PV} == "9999" ]] && eautoreconf
- if use pkg-config; then
- MULTILIB_CHOST_TOOLS+=(
- /usr/bin/pkg-config$(get_exeext)
- )
- fi
+ MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/pkg-config$(get_exeext)
+ )
}
multilib_src_configure() {
@@ -66,15 +64,8 @@ multilib_src_test() {
multilib_src_install() {
default
- if use pkg-config; then
- dosym pkgconf$(get_exeext) /usr/bin/pkg-config$(get_exeext)
- dosym pkgconf.1 /usr/share/man/man1/pkg-config.1
- else
- rm "${ED}"/usr/share/aclocal/pkg.m4 || die
- rmdir "${ED}"/usr/share/aclocal || die
- rm "${ED}"/usr/share/man/man7/pkg.m4.7 || die
- rmdir "${ED}"/usr/share/man/man7 || die
- fi
+ dosym pkgconf$(get_exeext) /usr/bin/pkg-config$(get_exeext)
+ dosym pkgconf.1 /usr/share/man/man1/pkg-config.1
}
multilib_src_install_all() {