summaryrefslogtreecommitdiff
path: root/dev-util/pkgcheck/pkgcheck-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-24 01:01:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-24 01:01:06 +0000
commitf52562a45d967e193210737b55de5f0ff9018b76 (patch)
tree909caa133f3a538fde8ed9dfd9efa42a2c7a0507 /dev-util/pkgcheck/pkgcheck-9999.ebuild
parent36fc50e36ed1a4686bb7202aeaff3170b2206124 (diff)
gentoo auto-resync : 24:03:2024 - 01:01:06
Diffstat (limited to 'dev-util/pkgcheck/pkgcheck-9999.ebuild')
-rw-r--r--dev-util/pkgcheck/pkgcheck-9999.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-9999.ebuild b/dev-util/pkgcheck/pkgcheck-9999.ebuild
index 2131d0f6f79e..1356e1a90511 100644
--- a/dev-util/pkgcheck/pkgcheck-9999.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_USE_PEP517=standalone
PYTHON_COMPAT=( python3_{10..12} )
inherit elisp-common distutils-r1 optfeature
@@ -33,13 +33,12 @@ else
>=sys-apps/pkgcore-0.12.25[${PYTHON_USEDEP}]"
fi
RDEPEND+="
- >=dev-libs/tree-sitter-0.20.9
- >=dev-libs/tree-sitter-bash-0.20.5
+ >=dev-libs/tree-sitter-bash-0.21.0[python,${PYTHON_USEDEP}]
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pathspec[${PYTHON_USEDEP}]
- >=dev-python/tree-sitter-0.20.4[${PYTHON_USEDEP}]
+ >=dev-python/tree-sitter-0.21.0[${PYTHON_USEDEP}]
emacs? (
>=app-editors/emacs-24.1:*
app-emacs/ebuild-mode
@@ -47,7 +46,7 @@ RDEPEND+="
)
"
BDEPEND="${RDEPEND}
- dev-python/wheel
+ >=dev-python/flit-core-3.8[${PYTHON_USEDEP}]
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]