summaryrefslogtreecommitdiff
path: root/dev-util/pkgcheck/pkgcheck-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-02 03:17:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-02 03:17:18 +0100
commit8f4c38a7c36dcb0533df606e6906314a00b70933 (patch)
treeecefade2e78e792adbecf221f91b52da6dd18b6f /dev-util/pkgcheck/pkgcheck-9999.ebuild
parentc69eea8c84cee05e6ba332fd1f39cfb6554d5726 (diff)
gentoo auto-resync : 02:08:2022 - 03:17:18
Diffstat (limited to 'dev-util/pkgcheck/pkgcheck-9999.ebuild')
-rw-r--r--dev-util/pkgcheck/pkgcheck-9999.ebuild32
1 files changed, 31 insertions, 1 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-9999.ebuild b/dev-util/pkgcheck/pkgcheck-9999.ebuild
index 44a8666a2eac..80366db8e2e5 100644
--- a/dev-util/pkgcheck/pkgcheck-9999.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_IN_SOURCE_BUILD=1
-inherit distutils-r1 optfeature
+inherit elisp-common distutils-r1 optfeature
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/pkgcore/pkgcheck.git"
@@ -20,6 +20,7 @@ HOMEPAGE="https://github.com/pkgcore/pkgcheck"
LICENSE="BSD MIT"
SLOT="0"
+IUSE="emacs"
if [[ ${PV} == *9999 ]]; then
RDEPEND="
@@ -38,8 +39,14 @@ RDEPEND+="
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pathspec[${PYTHON_USEDEP}]
>=dev-python/tree-sitter-0.19.0[${PYTHON_USEDEP}]
+ emacs? (
+ >=app-editors/emacs-24.1:*
+ app-emacs/ebuild-mode
+ app-emacs/flycheck
+ )
"
BDEPEND="
+ ${RDEPEND}
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
@@ -47,10 +54,22 @@ BDEPEND="
)
"
+SITEFILE="50${PN}-gentoo.el"
+
distutils_enable_tests setup.py
export USE_SYSTEM_TREE_SITTER_BASH=1
+src_compile() {
+ distutils-r1_src_compile
+
+ if use emacs ; then
+ pushd "${S}"/contrib/emacs >/dev/null || die
+ elisp-compile *.el
+ popd >/dev/null || die
+ fi
+}
+
src_test() {
local -x PYTHONDONTWRITEBYTECODE=
distutils-r1_src_test
@@ -60,9 +79,20 @@ python_install_all() {
local DOCS=( NEWS.rst )
[[ ${PV} == *9999 ]] || doman man/*
distutils-r1_python_install_all
+
+ if use emacs ; then
+ elisp-install ${PN} "${S}"/contrib/emacs/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
}
pkg_postinst() {
+ use emacs && elisp-site-regen
+
optfeature "Network check support" dev-python/requests
optfeature "Perl module version check support" dev-perl/Gentoo-PerlMod-Version
}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}