summaryrefslogtreecommitdiff
path: root/dev-util/pkgcheck/pkgcheck-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-27 15:12:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-27 15:12:15 +0100
commit246c83e768dd1efb42047de864a1e92b73de8b5c (patch)
tree2410761373aee7452a92e79038c5a28d631a0774 /dev-util/pkgcheck/pkgcheck-9999.ebuild
parente67c9b35124c5b3338943cf7793fe4402f03ad0f (diff)
gentoo auto-resync : 27:05:2023 - 15:12:15
Diffstat (limited to 'dev-util/pkgcheck/pkgcheck-9999.ebuild')
-rw-r--r--dev-util/pkgcheck/pkgcheck-9999.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-9999.ebuild b/dev-util/pkgcheck/pkgcheck-9999.ebuild
index 95b29b01a08f..25fe3d8378ba 100644
--- a/dev-util/pkgcheck/pkgcheck-9999.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit elisp-common distutils-r1 optfeature
if [[ ${PV} == *9999 ]] ; then
@@ -50,7 +50,9 @@ BDEPEND="${RDEPEND}
dev-python/wheel
test? (
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/requests[${PYTHON_USEDEP}]
+ ' python3_{10..11} )
dev-vcs/git
)
"
@@ -71,6 +73,16 @@ src_compile() {
fi
}
+python_test() {
+ if ! has_version -b "dev-python/requests[${PYTHON_USEDEP}]" ; then
+ EPYTEST_DESELECT=(
+ tests/checks/test_all.py::TestNetworkCheck::test_network_enabled
+ )
+ fi
+
+ epytest
+}
+
python_install_all() {
local DOCS=( NEWS.rst )
[[ ${PV} == *9999 ]] || doman man/*