summaryrefslogtreecommitdiff
path: root/dev-util/perf/perf-6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
commitd46d1d3a5897cade51811b3848c7bf27969da625 (patch)
tree0dabb04db53e3fe66abe43df0a3cdff5d3b664db /dev-util/perf/perf-6.3.ebuild
parente67d5b4ba05349b3bf4229d0cf7d069809c4420e (diff)
gentoo auto-resync : 28:12:2023 - 07:37:55
Diffstat (limited to 'dev-util/perf/perf-6.3.ebuild')
-rw-r--r--dev-util/perf/perf-6.3.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/dev-util/perf/perf-6.3.ebuild b/dev-util/perf/perf-6.3.ebuild
index 7969607f7994..e3f009470d74 100644
--- a/dev-util/perf/perf-6.3.ebuild
+++ b/dev-util/perf/perf-6.3.ebuild
@@ -179,6 +179,19 @@ perf_make() {
local arch=$(tc-arch-kernel)
local java_dir
use java && java_dir="${EPREFIX}/etc/java-config-2/current-system-vm"
+
+ # sync this with the whitelist in tools/perf/Makefile.config
+ local disable_libdw
+ if ! use amd64 && ! use x86 && \
+ ! use arm && \
+ ! use arm64 && \
+ ! use ppc && ! use ppc64 \
+ ! use s390 && \
+ ! use riscv
+ then
+ disable_libdw=1
+ fi
+
# FIXME: NO_CORESIGHT
emake V=1 VF=1 \
HOSTCC="$(tc-getBUILD_CC)" HOSTLD="$(tc-getBUILD_LD)" \
@@ -204,7 +217,7 @@ perf_make() {
NO_LIBBIONIC=1 \
NO_LIBBPF= \
NO_LIBCRYPTO=$(puse crypt) \
- NO_LIBDW_DWARF_UNWIND= \
+ NO_LIBDW_DWARF_UNWIND="${disable_libdw}" \
NO_LIBELF= \
NO_LIBNUMA=$(puse numa) \
NO_LIBPERL=$(puse perl) \